We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message

Bugs & Fixes: Fixing Apple TV lost network connections

Occasionally, my 1080p Apple TV (ATV) loses interest in connecting to my local network. More specifically, if I go to the Network setting I find no IP address listed. That's right. The IP address listing is empty. There isn't even an invalid self-assigned (169.x.x.x) address. Not surprisingly, when this vanishing act occurs, the ATV can no longer access my iTunes Library or any of the ATV's Internet-based services.

The Apple TV is hooked up to my network via a wired (Ethernet) connection. I had thought this would make for a more reliable connection. Apparently, not in this case.

Some quick diagnostic checks determined that the source of the problem was almost certainly the ATV itself. All the other networked devices--whether connected by Wi-Fi or Ethernet--were functioning as expected. My AirPort Base Station and Internet modem both showed all-systems-go. Even my second ATV, connected to another television, was working just fine.

Even the now troublesome Apple TV had been working for over a year without incident. The network loss popped up only in the last month or two. This made me wonder if the cause might be a bug in a recent ATV firmware update.

In any case, my first attempt to get the ATV back on the network was to restart the device. There are at least three ways to do this (as covered in an Apple support article). I had success with the first method: selecting Settings > General > Restart. Presumably, the others would have worked as well.

Unfortunately, a restart was not a permanent fix. The network loss continued to re-occur about once every two weeks. As long as restarting restored the connection, I wasn't too concerned. Still, I continued to seek a solution that would squash the bug entirely.

In one Apple Support Communities thread, numerous users have reported a similar Ethernet-based network loss. As in my case, restarting the ATV typically restored the connection. A permanent fix was more elusive. Various settings changes were recommended but none seemed to be a consensus solution. One posting suggested adding Google's Public DNS Server (008.008.008.008) to the network settings. But this assumes you already have a functioning IP address. I didn't.

Another thread described similar symptoms, except that they were with Wi-Fi connections. In one more thread, users reported a network failure limited to Home Sharing rather than the entire connection.

In at least some cases, the Wi-Fi failures may be due to a faulty ATV. As reported in a recent Macworld article, "a small subset" of third-generation Apple TV's qualify for a free replacement by Apple. To qualify, your device must have a serial number matching the criteria cited in the article.

I checked my Apple TV. My serial number was almost a match. It ended in the required DRHN. But it did not have one of the required third and fourth character pairs (instead, the matching pair was with the fifth and sixth characters). I assume that means close, but no cigar. Then again, my problem was with an Ethernet connection, not Wi-Fi.

Unfortunately, several questions remain unanswered. Do the Wi-Fi and Ethernet symptoms have the same underlying cause? For cases that do not qualify for a unit replacement, did a firmware update trigger the problem? If not, what is the sure-fire permanent solution? Hopefully, the answers will emerge sometime soon.

IDG UK Sites

Best Christmas 2014 UK tech deals, Boxing Day 2014 UK tech deals & January sales 2015 UK tech...

IDG UK Sites

LED vs Halogen: Why now could be the right time to invest in LED bulbs

IDG UK Sites

Christmas' best ads: See great festive spots studios have created to promote themselves and clients

IDG UK Sites

Why Apple shouldn't be blamed for exploitation in China and Indonesia