Apple has released Security Update 2006-007, updating a range of components of the operating system, from AirPort to PHP.

According to notes provided with the update, an issue was fixed with the AirPort wireless driver that could allow attackers on a wireless network to execute arbitrary code.

This issue affects eMac, iBook, iMac, PowerBook G3, PowerBook G4, and Power Mac G4 systems equipped with an original AirPort card. It does not affect systems with the AirPort Extreme card.

Other components of Mac OS X affected by this update include ATS, CFNetwork, Finder, Font Book, Font Importer, Installer, OpenSSL, PHP, PPP, Samba, Security, Framework, VPN, WebKit, gnuzip, and perl.

The update is available via the Software Update mechanism in Mac OS X or from Apple's website.