A vulnerability in Adobe Reader 8.1.2 could put PCs at risk, says Core Security.

The security company warns that malicious code could be embedded in JavaScript in a PDF and when opened via Adobe Reader could allow a hacker to take control of a third-party PC.

Adobe, which yesterday released a fix for the flaw, was unavailable for comment.

Ivan Arce, chief technology officer of Core Security told ZDNet: "We've seen similar vulnerabilities in JavaScript engines in Adobe software in the past and in other applications. It's difficult to avoid implementation bugs like this one".