Adobe has released a security update to address a cross-site scripting vulnerability in versions 7.0.8 and earlier of its Adobe Reader and Acrobat software.

The company also posted a security bulletin detailing server-side workarounds that website owners could use to prevent their sites from being co-opted into attacks using the vulnerability, which was disclosed last week.

The updates come less than a week after two security researchers in Italy disclosed a flaw in an Adobe Reader feature called Open Parameters that could allow remote attackers to inject arbitrary JavaScript into a browser session. The discovery of the flaw caused considerable concern because of the ease with which it could be exploited and because it allowed any website hosting PDF files to be used to carry out an attack.

In response to those concerns, Adobe last week urged all users of its software to upgrade to version 8.0 of Adobe Reader and Acrobat, both of which were unaffected by the flaw. At that time, the company said it would release patches addressing the issue for users who wanted to continue using older versions of the two programs.

This week's security update from Adobe also addressed additional vulnerabilities identified in versions 7.0.8 and earlier of Reader and Acrobat, the company said. The vulnerabilities, which have been assigned a 'critical' severity rating by Adobe, allow for attackers to take complete control of an affected system.

"One way to prevent the Adobe Reader and Acrobat Plugins from passing JavaScript to the browser is to force PDFs to open outside of the browser and Adobe Reader or Acrobat Professional," the company said. Another way to mitigate the risk is "consider creating server-side code (ColdFusion, Java, PHP, ASP.NET, etc.) to read the file and send it back as part of the Response", the company noted.