We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
80,259 News Articles

Critical remote code execution vulnerability fixed in Exim email server

Exim 4.80.1 addresses vulnerability in DKIM handling code that could lead to system compromise

Developers of the popular Exim email server software released an emergency update on Friday to address a critical vulnerability that could allow attackers to execute malicious code on the underlying operating system.

The vulnerability was located in the code responsible for performing DomainKeys Identified Mail (DKIM) verifications, a feature enabled by default in Exim installations.

DKIM allows associating domain names with email messages through the use of digital signatures that can be verified by the recipient email server. Its goal is to prevent email address spoofing.

The patched vulnerability is a heap-based buffer overflow and can be exploited by anyone who can send email from a domain name for which they control the DNS (Domain Name System) records, Exim developer Phil Pennock said Friday in an email announcing the release of Exim 4.80.1.

"This is a SECURITY release, addressing a CRITICAL remote code execution flaw in versions of Exim between 4.70 and 4.80 inclusive, when built with DKIM support," Pennock said.

The vulnerability is rated as critical and was identified during an internal review of the DKIM-related code in Exim.

The code review was prompted by two DKIM implementation issues that were disclosed last week and affected multiple email providers including Google, Microsoft and Yahoo.

"I apologize for the impact of releasing this on a Friday," Pennock said. "I do not consider there to be an acceptable alternative."

"I expect that this area of code in various MTAs [mail transfer agents] will be studied by many security conscious people around about now, so there is a significant risk that someone unfriendly has also discovered this, concurrently to our finding it," Pennock said.

Exim is one of the most popular mail transfer agents. It is installed by default in Debian Linux and other Debian-based Linux distributions like Ubuntu. It is also commonly used together with the popular Mailman mailing list software and the cPanel Web hosting server administration platform.

Most Linux vendors have already released updated Exim packages through their respective repositories, so users are encouraged to install them.


IDG UK Sites

Black Friday 2014 tech deals UK: Today's bargains phones, tablets, laptops and more for Black...

IDG UK Sites

Black Friday feeding frenzy infects the UK

IDG UK Sites

VAT MOSS: Will I be affected by the EU VAT changes? Here are the facts for designers and artists

IDG UK Sites

Black Friday 2014 UK: Apple deals, Amazon deals & Black Friday tech offers