We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
80,258 News Articles

Adobe fixes Acrobat & Reader PDF flaw

Windows XP users urged to update now

Adobe has tackled a flaw which exposed Windows XP PCs to exploits arriving in malicious PDF files.

The patches are included in updates to Reader, the free PDF rendering utility, and Acrobat, Adobe's full-featured application; both have been tagged as Version 8.1.1.

"Critical vulnerabilities have been identified in Adobe Reader and Acrobat that could allow an attacker who successfully exploits these vulnerabilities to take control of the affected system," Adobe warned in a bulletin that detailed the patch availability. "A malicious file must be loaded in Adobe Reader or Acrobat by the end user for an attacker to exploit these vulnerabilities."

Only users of Microsoft's Windows XP who have Internet Explorer 7.0 installed are at risk of such attacks, Adobe added.

The patches come a little more than two weeks after Adobe acknowledged the bug and posted a complicated work-around that required users to edit the Windows Registry.

Adobe is the most recent application developer to patch its software against a Windows-wide vulnerability that Microsoft has owned up to but has yet to fix. On 10 October, Microsoft's security team admitted that Windows XP and Windows Server 2003 mishandle some URIs (Uniform Resource Identifiers) and promised to provide a fix in the future.

Even then, however, Microsoft said third-party developers had to shoulder some of the responsibility. "While our update will help protect all applications from malformed URIs, application vendors that handle URIs can also do stricter validation themselves to prevent malicious URIs from being passed to ShellExecute," said Jonathan Ness, a program manager at the Microsoft Security Response Center, nearly two weeks ago.

Other vendors that have updated their software include Mozilla and Skype, who patched the Firefox browser and the Skype VoIP (voice over IP) software, respectively, back in July.

The PDF vulnerability was disclosed in September by UK-based researcher Petko Petkov, who said that attackers could compromise a PC simply by persuading users to open a PDF document or view a web page with embedded PDF content.

Links to the Adobe Reader 8.1.1 and Acrobat 8.1.1 updates are available in Adobe's security bulletin.


IDG UK Sites

Samsung Galaxy Note 4 review: Great if you like big, expensive phones

IDG UK Sites

Why Sony's PS4 2.0 update is every gamer's dream (well, mine at least)

IDG UK Sites

This Grolsch ad combines stop-motion & CG for majestic results

IDG UK Sites

Apple rumours and predictions for 2015: What to expect from Apple in 2015