We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
80,259 News Articles

Rival browsers to get Firefox security tool

Service checks for outdated plug-ins

Mozilla is allowing web users running rival browsers to use Firefox's new plug-in update service.

This week, Mozilla launched a web-based service that checks for outdated Firefox plug-ins. The service, which relies on a web page users must steer to manually, is part of the company's effort to prod people into upgrading potentially-vulnerable add-ons, such as Adobe Flash Player, which have become a major target for attackers.

The check scans for installed plug-ins, identifies those for which updates are available and provides a link to the vendor's download site.

Although the service currently works only in Firefox , a pair of Mozilla managers said that the company wants to open the plug-in check to other browsers.

"Right now, this page only works with Firefox, but we care about all of you and we're working to support those of you on other browsers as well," said Asa Dotzler , Mozilla's director of community development.

In fact, the service already detects plug-ins when the page is accessed by some browsers, such as Apple's Safari, although it isn't able to tell which plug-ins are outdated.

However, other browsers, including Microsoft's market-leading Internet Explorer (IE), can't use the page: When IE8 reaches the check-in page, the message 'No plugins were detected' appears.

Johnathan Nightingale, the manager of the Firefox front-end development team, confirmed Dotzler's comment about future plans for the service.

"Right now, we're focused on expanding our plug-in coverage and trying to bring greater consistency to the way this information is reported," Nightingale said.

"Longer term, we'd like to make the page as universal as possible, both in terms of the plug-ins we check and the browsers people can use when they visit."

According to another Mozilla blog , the plug-in checking service can also be called by any external site using a JavaScript API.

Mozilla has already promised to add more plug-in checking functionality to the next version of its browser. Firefox 3.6, which is slated to launch in beta this month, will warn users when they visit a website that relies on an outdated plug-in.

The plug-in check service detects more than a dozen different plug-ins, but isn't always able to tell whether one is outdated. For example, we found Adobe's plug-in to render PDF documents within the browser, was detected on a system running Windows XP, but the checker said it couldn't sniff out the version number.

Mozilla kicked off its campaign to eradicate out-of-date plug-ins last month, when it shipped a Firefox update that included detection for only Adobe Flash Player.

Later, Mozilla said that the Flash check had prompted more than 10 million users to go to Adobe's website to download the newest version of Flash.

Broadband speed test

PC security advice

See also: Firefox 3.6 will detect your screen orientation


IDG UK Sites

Where to buy iPhone 6 and iPhone 6 Plus in the UK: Launch day price, deals and contracts

IDG UK Sites

Is Apple losing confidence in itself?

IDG UK Sites

Professional photo and video techniques for perfect colours

IDG UK Sites

How (and where) to buy an iPhone 6 or iPhone 6 Plus in the UK. Plus: What to do if you pre-ordered...