We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
2,862 Tutorials

Troubleshoot your motherboard's network adaptor

What to do when your PC motherboard's network adaptor goes wrong

When a reader noticed that the LED on his PC motherboard's Realtek LAN adaptor was permanently on, our Helproom Expert diagnosed a software or driver issue, and showed how to troubleshoot your motherboard's network adaptor.

QUESTION My Asus M4A88T-M motherboard has a Realtek LAN adaptor. Following a recent update, I noticed that its activity LED light remains lit regardless of whether the cable is attached. This is not the case when plugged into another PC.

Network Diagnostics stated that ‘Windows did not detect a properly installed adapter. If you have a network adapter, you will need to re-install the driver'. I reinstalled the driver, then got the message: ‘The Realtek network controller was not found. If Deep sleep mode is enabled, plug in the cable'.

I have not enabled deep sleep mode, nor do I know how to. I've tried starting up the computer without the LAN cable plugged in, and again with it attached. Neither solved the problem.

My online research found several others who have had the same problem, but their suggested remedies – removing the memory cards and battery, and clearing the CMOS – have not helped. Wallace McLarty

HELPROOM ANSWER The network adaptor problem is indeed a tricky one, and all sorts of different tricks have been employed to resolve this issue with varying levels of success. That this occurred immediately after an update suggests that it's a software or driver problem rather than there being something physically wrong with your network adaptor. Any re-setting of the motherboard will only be able to fix things if it can trick Windows into reloading any problem drivers.

First, try booting a live version of Linux, such as Ubuntu, which is free. You can download and burn a CD and boot into that. There's every chance that your onboard network adaptor will work fine under Ubuntu. If it does, we'll know that it's a Windows configuration problem and the problem you're having is caused by drivers that aren't right for your network hardware.

If this is the case, you'll need to download and install the latest drivers for your motherboard. These can be obtained from Realtek's website, at tinyurl.com/La9ey.

Be sure to grab the right version – for your motherboard you'll need RTL8111E.

See all How to articles. Get free tech support in the Helproom Forum.

Visit Windows 7 Advisor for more Windows advice.

IDG UK Sites

Nexus 6 vs Samsung Galaxy Note 4 comparison: What's the best Android phablet?

IDG UK Sites

The iPhone is doomed. Doomed to be marginally less successful than a very successful thing.

IDG UK Sites

How to prototype native mobile apps without writing code

IDG UK Sites

How to prepare for and update to OS X Yosemite: Get your Mac ready to download & install Apple's...