Old satnav

Buying an old satellite navigation device can be a good idea, if you can update the maps which quickly become out of date. Our Helproom Editor tries to help one reader who is trying to update an old satnav.

QUESTION I bought an old Navigon PNA Transonic 6000 from a charity shop and would like to update its maps, but the manufacturer no longer supports the device. I found and downloaded a UK map file, but the satnav won't read it. I suspect this is because its software is out of date. I think I've found a newer version of the software on torrent sites, but any help you can give me on installing it will be a bonus.

HELPROOM ANSWER The PNA 6000 won't work with the latest map file because it's based on WindowsCE 4.2 and MobileNavigator 5, whereas the current software uses WindowsCE 5 and MobileNavigator 7. The latest version you can use is MobileNavigator 6, but we weren't able to find a legitimate site from which you can download it. We recommend contacting the manufacturer to see whether it can help.

See all How to articles. Get free tech support in the Helproom Forum.

Visit Windows 7 Advisor and Windows 8 Advisor for more Windows advice. Or email our Helproom Editor for bespoke advice.

See also: Satnav buying advice.