We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Windows Help


It's free to register, to post a question or to start / join a discussion


 

simpletech simple drive 250gb drive


brianp65

Likes # 0

Hi. I have an external drive Simple Tech, Simple Drive model 96300-41001-011 which i have not used in a while. it should have the drivers built in but when i plug it in it runs but does not appear . Simple Drive does not appear in COmputer. I plug it into my Sony G11VN pc running Vista Business sp2. The usual window pops up “windows needs to install driver software for your Simple Drive” – I click “locate and install driver software” but it does not find it. I have looked for the driver on the site of Simple Tech which is now www.hgst.com but I can’t find it.

Have tried to plug into MacBook which also runs windows with no luck.

Any ideas? Where can I find the driver?

Like this post
Jock1e

Likes # 0

Does it show in my computer.

Look in device manager to see if any yellow exclamation marks against the driver.

Like this post
brianp65

Likes # 0

thanks for reply Jock1e. no it does not appear in my computer and yes there is a yellow ! in devise manager. i have tried updating driver but it can't find the the driver and have tried disabling/enabling and also uninstall/reinstall. no luck. aslo does not appear in Disk Management

Like this post
brianp65

Likes # 0

i have a feeling that the drive is not compatible with Vista. I just remembered that I used to use it with an old Toshiba pc with windows ME, which i still have. have tried it and it works. oh well!! thanks anyway for your help.

Like this post
Jock1e

Likes # 0

Maybe try reformating it if you can to see if that makes any difference. You would loose anything that is on it mind you.

Like this post
brianp65

Likes # 0

i had already tried formatting on the ME pc. still not appearing on Vista PC. no problem. the latest driver i can find is for XP

Like this post
jaywoo

Likes # 0

It shouldn't need any drivers for Vista, Windows Compatibility Centre says those drives work all the way up to Windows 8.1

Here are some troubleshooting steps; click here you have it plugged in to the mains or are you relying on USB power alone?

Do

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

5 things we want to see in Android M: New features and fixes

IDG UK Sites

iPad mini 3 release date rumours: 'iPad mini Air' will be 30 percent thinner than current model

IDG UK Sites

Introducing generation tech

IDG UK Sites

This animated film reveals the importance of designing for everyone