We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Windows Help


It's free to register, to post a question or to start / join a discussion


 

Devices And printers page is Blank


catpwss
Resolved

Likes # 0

Hi.I have a laptop running windows 7 home premium. Over the past few days something very strange has happened,When I open the Devices & printers page from the start method Its Blank nothing there I have a cordless mouse , And its connected to a home group. The strange thing about it when I want to print a document etc I select the print method and it shows my default printer and my wireless printer on the drop down menu but nothing shows up in the Devices & printers page. Have tried a system restore that didn't do anything.Also did a scannow with no joy.

Any help here please. Thanks.

Like this post
difarn

Likes # 0

Have you at any time deleted a user account? You may be interested in this article that offers some advice and possible solutions although these have now worked for some people.

Like this post
difarn

Likes # 0

Correction - should have read "not worked....." instead of "now".

Like this post
catpwss

Likes # 0

Thanks for reply I'm the only user.have not deleted anything. Very strange.

I did see this upon googleing it was to copy and paste into command prompt. I did that and all the printers were there,But on the top it said Control panel > All Control Panel Items > Printers. But closed that page and went to see in the page where they should be but nothing there.

This is what I pasted into command prompt start shell:::{26EE0668-A00A-44D7-9371-BEB064C98683}\0\::{2227A280-3AEA-1069-A2DE-08002B30309D}

Thanks.

Like this post
difarn

Likes # 0

Some advice from Microsoft support is

Open Task manager. Go to Services TAB. In the long list of services look for BthServ Right Click on it and Start Service. If you want this setting to become permanent, then you need to Click on the Small Services Button in the task manager below the listed services. A new window called services will open up. Click Extended at the base tab. Look for Bluetooth Support Service. Right click on it and properties. Change Startup type to Automatic. Then Click Start Apply and ok.

Worth a try

Like this post
catpwss

Likes # 0

difarn. Many thanks for that bit of gen,I gave it a go but sorry to say no luck. Thank for the help.

Like this post
catpwss

Likes # 0

difarn.Hi another day another dollar.Well here we go again,I gave up I got a mate that runs a pc shop with his father asked him this morning and we decided to do a clean install as the laptop is over 3year old. Going to be done on tuesday. I want to thankyou for the help you provided. thanks.

Like this post
difarn

Likes # 0

It is amazing how many people are having the same problem - the majority of whom have had to resort to doing what you are about to do. Sorry couldn't have been of more help but I have drawn a blank. Hope it works.

Like this post  
catpwss

Likes # 0

difarn. Thought that I would get back to you with my problem,Got the windows re installed now have a fresh windows 7 laptop. Working well.

many thanks for you advice earlier on.

Like this post
difarn

Likes # 0

Thanks for coming back and glad that it is now sorted.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Swatch to release its own line of smartwatches to rival iWatch

IDG UK Sites

From the iPhone 6 to the iWatch and a new Apple TV we look at the products Apple is set to launch...

IDG UK Sites

Miranda July's Somebody app offers a very unusual take on messaging

IDG UK Sites

The 7 most ridiculous iPhone 6 rumours: what Apple WON'T reveal on 9 September