We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:

PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Windows Help

It's free to register, to post a question or to start / join a discussion


connect windows 8 to the internet


Likes # 0

I purchased the win 8 upgrade from microsoft and then installed on a brand new lenovo laptop running windows 7 all ok until tryed to connect to the internet and it came up please connect modem we went through all the checks as recommended by microsoft with no effect though the laptop was working across the network reverted back to the windows 7 image all ok. Then tried a to update a desktop with a brand new copy of win 7 installed again the same problem networked ok would not connect to the internet spoke to microsoft who again ran through all the checks and they ran out of ideas reverted back to win 7 all ok spoke to talk talk who supplied the router they had no idea [have done all the usual reboot router refresh ip etc. have spoken to microsoft to try and get our money back basiclly the software is not fit for purpose


Like this post

Likes # 0

Sometimes these things happen. You upgraded via wireless? It will be a wlan card driver fault. Lenevo's not Windows. This time connect via ethernet then upgrade. Use Windows update and update the lot. If wlan still doesn't work, contact Lenovo as it's their product.

With the desktop doing the same, connected via cable(?), I'd have a word with your ISP again but possibly you need to connect to your (modem) router to check that your settings, passwords, etc are correct. Try upgrading again and then rebooting the router. It might be the supplied router/modem's fault.

Nothing else I can think of.

Like this post

Likes # 0

" all ok until tried to connect to the internet and it came up please connect modem"

That might suggest that it is attempting to connect to the internet with a "dial-up" connection, either a USB ADSL Modem or a V.90 type dial-up modem.

If you still have Windows 8 installed, go to "Control Panel > Internet Options", select the Connections tab and ensure the option Never dial a connection has been selected.

Like this post

Reply to this topic

This thread has been locked.

IDG UK Sites

Why I think the Apple Watch sucks and you'd be mad to buy it

IDG UK Sites

Swatch launches a colourful smartwatch

IDG UK Sites

New Apple TV 2015 release date rumours: TV streaming service delayed, hand gesture interface being...