We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Windows Help


It's free to register, to post a question or to start / join a discussion


 

LoveFilm Instant on Windows 8 (Pro N)


glawrence1986

Likes # 0

Hi all,

I've recently upgraded to Windows 8 Pro N, and have been trying to play LoveFilm Instant films with no luck. I've tried the following browsers: - Google Chrome using the 'New Windows 8 UI' - Google Chrome using the desktop environment - Internet Explorer 10

In order to try and fix the problem, I've also tried the following: - Check that Silverlight settings are correct (according to LoveFilm FAQs) - Re-install of Silverlight (Many times) - Running Silverlight/Browsers as administrators - Running Silverlight/Browsers in compatibility mode of Windows 7 - Refresh, and complete re-install of Windows 8

I've now reached out to LoveFilm, but am wondering if I'm the only one with this problem, or if there are any solutions that people know of.

Any help would be much appreciated.

Gary

Like this post
aquatarkus

Likes # 0

You have the N version of Windows 8. Windows Media Player is NOT installed with the N versions of Win8 you need to download and install a media player something like VLC media player would be ideal as it can play almost anything you throw at it

Regards Aquatarkus

Like this post
rdave13

Likes # 0

You can also download Windows Media Center for free. click here

Like this post
glawrence1986

Likes # 0

Hi. Thanks for your posts - I had installed Windows Media Player Yesterday anyway, but didn't realise it would change anything so didn't try LoveFilm again after (As Lovefilm streams using Silverlight through the browser).

I have tried again this morning just to check, and it does now work. Do you think it could be because I've installed Media Player then?

With regards to Windows Media Centre, something for another thread perhaps, but there is a problem adding it to some Windows Pro versions (Including mine). I have signed up for and been given a free key from Microsoft, but there is literally no option to 'adding new features' as their guide advises. Other threads I've read confirm this is a known problem, but I don't know whether anything will be done to fix it.

Thanks again, I can now watch LoveFilm again so am really pleased :-)

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

5 things we want to see in Android M: New features and fixes

IDG UK Sites

iPad mini 3 release date rumours: 'iPad mini Air' will be 30 percent thinner than current model

IDG UK Sites

Introducing generation tech

IDG UK Sites

This animated film reveals the importance of designing for everyone