We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Windows Help


It's free to register, to post a question or to start / join a discussion


 

Windows 7 Sleep Function


bpzoom
Resolved

Likes # 0

I put this on the wrong forum, so here it is on the correct one. Lately the Del Desktop PC with Windows 7 64 bit refuses to come out of sleep when it has been left for a period of hours. When I manually send it to sleep it does so and the mouse and keyboard are set to revive it. It revives as it should do if I move the mouse or hit a key. However whenever I leave it asleep for a long period such as several hours, it refuses to awake and I have to force a reboot with the power button. That produces the black screen which you get after a crash. Any ideas what might cause it to revive after a short period of sleep but not after a long period? I have changed nothing except that I have applied Windows updates.

Read more: http://www.pcadvisor.co.uk/forums/1/helproom/4142092/windows-7-sleep-function/#ixzz1vJvbbXGg

Like this post
rdave13

Likes # 0

Like this post
bpzoom

Likes # 0

Thanks I had already gone there, but none of the solutions there apply to a problem of failing to wake after sleep. My settings are as they suggest they should be.

Like this post
johndrew

Likes # 0

This sometimes happens as a result of graphics drivers either not installing properly or being corrupt; it can also happen if you have a number of programs running or have a lot of RAM in use when you select 'Sleep'.

I have had experience of this in both XP Pro and W7 Pro 64bit where either the PC will not respond to mouse/keyboard input at waking or I have a black screen (screen indicating hibernate mode) where the graphics fail to provide a signal.

There can be other causes as well as this MS forum question/answer indicates. There are other answers as well, such as:

Answer 1 Answer 2 Answer 3 As you can see, it is worse for some than others. If you Google 'w7 fails to wake from sleep' you will get a lot of hits and although a hotfix was provided for PCs with multi CPUs the problem is still apparent.

You could try reading the MS troubleshooter for this but how well it will work for you ......

Like this post
northumbria61

Likes # 0

I do agree with johnandrew comments but I am of the opinion that sleep mode is intended mainly for laptops - whilst it may be useful or an easy option for a desktop there is nothing to beat a "cold start"

Like this post
bpzoom

Likes # 0

Thank you both for that advice. I have to say that a friend far more savvy than me also has the same problem except his W7 is a 32 bit version.

Like this post
rdave13

Likes # 0

When it goes to a deep sleep try pressing the reset button on the PC, if you have one, then tap the key for the temporary boot options, select the hard drive and it will boot. If you don't have the reset button then simply press and hold the start button. Once you hear the system starting then keep tapping F8 or the Esc key at boot up. Find out how to get the temporary boot up order screen on your PC. Select the drive with your OS(usually C:/) then it should boot up.

Like this post
bpzoom

Likes # 0

I tried one suggestion under http://www.pcadvisor.co.uk/forums/28/windows-7/4142107/windows-7-sleep-function/#ixzz1x8fvyQpF, which was start>control panel>power options>in your preferred plan change plan setting>change advanced power settings>pci express>link state power management >change to off and apply.
This seemed to work OK for short periods of sleep up to one hour. But when I left it for 2+ hours, it failed to awake from sleep. Until something turns up, in future I will power off for longer periods. The Dell does not have a reset button.

Like this post
bpzoom

Likes # 0

rdave13 many thanks for your help. You said - Go to device manager and double click universal serial bus controller and in the usb root hub list, right click each one, select properties, click on the power management tab and untick Allow the computer to turn off this device to save power. See if that helps. Your suggestion so far has worked on short spells and with one spell of over 2 hours. I have no idea how it worked but I am grateful nevertheless. I will be sensible and switch off when I know I will be away from the machine for spells in excess of 2 hours. Thank you.

Like this post
cutegirl57

Likes # 0

I know I will be away from the machine for spells in.......... Thank you.

Kizi

Like this post  
bpzoom

Likes # 0

I regret to say that after two days of working fine, the sleep problem has returned. I think I will just have to live with it. My neighbour also with W7 and the same problem has run through all the suggested solutions and it has not worked.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Sony PlayStation 5 release date, price and specs UK: When is the PS5 coming out?

IDG UK Sites

New Apple TV release date rumours, features: 'new Apple TV next week' rumour

IDG UK Sites

Mobile email is powerful and useful - but also hopelessly intrusive

IDG UK Sites

How the Oculus Rift VR headset is helping train the surgeons of tomorrow