We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Windows Help


It's free to register, to post a question or to start / join a discussion


 

WMP copies CDs but can't play them on USB key


mousee

Likes # 0

Is driving me mad, I'm running a Windows 7, 32 bit laptop and have been ripping CDs to copy onto my USB drive to play in the car, I got about 50 CDs copied tonight and transfered to the USB, I tried it in the car and it was fine, had my tea and copied the rest, tried it in the car and only the ones I'd copied before tea will play, plugged the USB back into the laptop and tried to get it to play using Windows Media Player, the message I'm getting on screen shows this-:

"Windows Media Player cannot play the file. The Player might not support the file type or might not support the codec that was used to compress the file."

Can anyone let me know what I can do to fix this please?

Like this post
difarn

Likes # 0

I don't suppose the little slider on the usb stick has accidentally been moved protecting the contents?

Have you had a look at what is on your usb stick? Can you see if all of your music has been put into the same folder or have two folders been created? If two folders have been created then it is possible that the player in your car is only recognising one.

When you have ripped your cd's to WMP do you then transfer them to your stick by clicking on "my computer" and double clicking on the usb icon and leaving this open - then select "my music" then dragging and dropping this folder onto your usb stick in my computer?

Like this post
mousee

Likes # 0

There is no slider on the USB, I've copied the CDs the way you've described by having two windows open, to no avail and there is only one folder. I've also tried by using the "send to" option, this doesn't work either, another thing, when I copy them to the USB, I get an empty folder, it seems to me that there is a codec problem, but I've tried to find the missing one(s) but without success. I'm wondering if I should back the machine up and do a full reinstall.

Like this post
difarn

Likes # 0

The strange part is that the first batch played ok and, if you didn't change any of the WMP settings when you transferred the second batch to the usb then there is no reason why the tracks should not play.

I would be inclined to check the format of the files in the first batch -

To determine what codec was used with a specific file, play the file in the Player, if possible. While the file is playing, right-click the file in the library, and then click Properties. On the general tab you will see the format - assume this is MP3.

then re-install the second batch making sure that you use the same format.

As far as the message about codecs is concerned can I suggest that you make sure that your drivers for your Sound Card and Video Card are up to date. Also that Direct X is the current version - this article gives you the link/

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Best Black Friday 2014 tech deals UK: Get bargains on phones, tablets, laptops and more this Black...

IDG UK Sites

Tomorrow's World today (or next year)

IDG UK Sites

25 iOS apps turn (Red) for World AIDS Day campaign

IDG UK Sites

Advanced tips for Mac OS X Yosemite: use Yosemite like an expert - 5 new tips added