We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Windows Help


It's free to register, to post a question or to start / join a discussion


 

network card - unwanted power down


keith mac

Likes # 0

I have two laptop computers. Both dual boot Unbuntu Linux 11.04, one uses Vista, the other Windows 7. Both are configured, to the best of my limited ability, to start up, sleep and close down as quickly as I can make 'em do it. Both run on mains power and software is configured for maximum performance.

Each computer's Power button is configured so they go into Sleep mode. The Vista one is hopeless at waking up and I use Linux most of the time. The W7 one sleeps reliably using either o/s. What I find, though, is although either computer appears to be active, I can't get online for a time. That can be a second or two or much longer. I can see no consistency or pattern.

The wifi / ethernet icons show that the power to the network card gets switched off before the computers enter Sleep mode. It also shows the card is slow to re-connect to the Internet. This slows down the otherwise speedy re-activation of the computers. I guess it's hardware activated as in both Linux and Windows on both computers I find much the same, albeit Linux is always quicker to eventually get moving.

How can I stop the network card being powered down when entering Sleep mode?

Like this post
difarn

Likes # 0

You could try this

Go into Device Manager

Open Network Controller properties by:

Double-click Network adapters to expand it
Double-click the Network Controller

Turn off Deep Sleep mode by:

Choose the Power Management tab
Untick “Allow the computer to turn off this device to save power”
Like this post
keith mac

Likes # 0

thanks but all such settings were configured long ago - and it's not just in Windows as Linux does the same - that's why I was guessing hardware

Like this post
difarn

Likes # 0

Saw this in a thread which may be of interest:-

"The problem starts when the computer goes into sleep/standby mode, a few components of the PC including the network controller (or adapter) are turned off. The issue occurs when the PC wakes up and power to everything is restored. The network controller doesn’t come on - I ordered a PCI ethernet card. I unplugged power to the system, plugged in the PCI card, plugged the power cord back in, and restarted the system. Windows 7 then re-installed the drivers for the Realtek on-board ethernet controller."

Like this post
keith mac

Likes # 0

It might be relevant. I have the same problem on each computer and I'll have to check if they both have network cards from the same manufacturer.

The Vista one might need an updated driver but the W7 one isn't that old - and both have the same problem which would mean it's a bug from several years back - does it sound likely?

Like this post
difarn

Likes # 0

I have a feeling it is something to do with the Vista PC as there are many problems with the sleep mode.Were there any Vista updates downloaded recently?

Are your PC's on a network?

Have you tried changing the power plan setting on the Vista to see if that has any effect at all?

select start/control (click on classic view) select Power Options click on one of the Power Plans (select High Performance) then click on 'change plan settings' now click on 'put the computer to sleep' select NEVER. Reboot.

Do you have IPv6 checked by any chance? If so try unchecking this leaving just IPv4. Link here to changing TCP/IP settings if you need it.

I have a home network with wired XP and Windows 7 desktops,three wireless laptops - two XP and one Vista and looking back I remember having similar problems with the Vista set-up - I don't really need the laptops to go into sleep mode so I power them down when not in use instead.

It still remains a puzzle - could be an old bug as you say but judging from the amount of articles about pretty much the same problem I doubt it.

Like this post
keith mac

Likes # 0

I have a feeling it is something to do with the Vista PC as there are many problems with the sleep mode.Were there any Vista updates downloaded recently? Much the same happens with W7 and with Linux..... I've installed whatever Vista updates there have been - I don't especially recall any recent ones but, then we're always getting 'em!

Are your PC's on a network? No

Have you tried changing the power plan setting on the Vista to see if that has any effect at all? Yes - I've configured every setting I can locate which would power-down anything at all - everything runs on mains so I only use Sleep or total Shut Down - nothing in between.

select start/control (click on classic view) select Power Options click on one of the Power Plans (select High Performance) then click on 'change plan settings' now click on 'put the computer to sleep' select NEVER. Reboot. already done all that....

Do you have IPv6 checked by any chance? If so try unchecking this leaving just IPv4. Link here to changing TCP/IP settings if you need it. I'll have to look for this later....

I have a home network with wired XP and Windows 7 desktops,three wireless laptops - two XP and one Vista and looking back I remember having similar problems with the Vista set-up - I don't really need the laptops to go into sleep mode so I power them down when not in use instead. But what of W7 and Linux - both computers dual-boot into either o/s and in each o/s the power is switched off to the network card before Sleep happens - at least that's what the icons indicate. It's only Sleep I'm concerned about

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

OnePlus Two release date rumours: Something's happening on 22 July

IDG UK Sites

13in MacBook Air review, Apple's MacBook Air 2014 reviewed

IDG UK Sites

5 reasons to buy an electric car and 5 reasons not to

IDG UK Sites

Just graduated? Learn all you need to know to kickstart your career in our Creative Graduate Guide