We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Windows Help


It's free to register, to post a question or to start / join a discussion


 

Icons VERY slow


Meredith

Likes # 0

Hi

I've tweaked the Registry to include a new string called Max Cached Icons and set this to a value of 8192, as I've read reports on other forums of this solving the problem of Windows 7 icons being really slow to re-draw. I've also deleted and re-built the icon cache.

Neither of these seems to have made much difference. Is anyone else expereincing this?. and has anyone got any other suggestions to try?

I'm running Windows 7 Professional SP1 64 bit.

Like this post
ams4127

Likes # 0

I've heard on another site that this problem can be caused by having too many processes running. Start Task Manager and check how many are running. More than about 25 is probably too many.

Do not use Task Manager to kill them. Run Msconfig and disable as many startup items as possible.

Hopefully this will help.

Like this post
Meredith

Likes # 0

OK, thanks. I'll look into this, although if it's a memory related issue, then I've got 12Gb RAM, so surely this would be enough?

I've also read some reports on other forums that Microsoft Security Essentials can create this problem - so if that is true, I guess I'm stuck with it.

Seems a shame that Windows 7 still has some clunky bits in what is otherwise an excellent OS.

Like this post
ams4127

Likes # 0

I don't think your problem is a RAM matter, rather that there are too many processes running at the same time which is proving too much for your processor.

I have checked mine and have 18 processes running. All un-necessary startups have been disabled or deleted.

Like this post
Meredith

Likes # 0

Hi

It seems to have started recently, and maybe since I installed MS Security Essentials, which is the only AV and spyware program I have installed.

My PC spec is Intel Core i7 3.2Ghz; 12Gb DDR3 RAM; Nvidia GTX295 graphics.

There's a total of 18 processes loading on Start Up, and I keep these to a minimum using SysInternals Autoruns, rather than through services.msc.

The icon performance does improve after deleting and rebuilding the icon cache, but then gradually seems to deteriorate over time. On checking around in Google, it seems that this is quite a common problem with other Vista and Win 7 users, so I'm certainly not the only one who's experiencing this.

I'll see what happens if I disable MS Security Essentials, because there have been some reports that this program causes a slow down in ocons re-drawing - but I've no idea why though!

Like this post
Meredith

Likes # 0

It's all icons, expecially the taskbar, but also Control Panel > Programs and Features.

Like this post
Meredith

Likes # 0

It's all icons, expecially the taskbar, but also Control Panel > Programs and Features.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Samsung Galaxy S6 release date and specs rumours: When will the Galaxy S6 come out?

IDG UK Sites

How to win iTunes Festival 2014 tickets: See Pharrell Williams, Sam Smith, Kylie & more live, for...

IDG UK Sites

Microsoft's all or nothing bet on Windows Phone is the best way forward

IDG UK Sites

Google adds better type rendering to its Chrome browser on Windows