We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Windows Help


It's free to register, to post a question or to start / join a discussion


 

Epson Photo R200 not working on Vista??


jemjem

Likes # 0

Hi,
I've recently had Vista put on my computer and now my printer doesn't work. I have tried unplugging the printer, uninstaling any epson software by going to computer- add/ remove programmes. Then deleting the printer in control panel. I then plugged the printer back in and installing various epson drivers such as easyprint 310a. Nothing works :( I've also tried restarting before plugging the printer back in and it's still not having it? Can anyone help?
Thanks
Jemma

Like this post
Kevscar1

Likes # 0

have you gone to the Epson site to see if there is a Vista driver for your printer.

Like this post
Peter

Likes # 0

.

I think with Epson printers that you must install the drivers from the CD (or download) before you plug in the printer. You will be prompted to plug in and switch on the printer during the driver installation process.

Peter.

Like this post
jemjem

Likes # 0

Hi again, Thanks for the advise.
I've looked on the epson website and there is nothing for this printer and vista. I downloaded the easyprint but as it was the only one that mentioned vista but its not a driver, I also tried one that was for XP, but it wouldn't let me install it. Do you think a driver for a differant printer in the same series would work?

Like this post
sharpamat

Likes # 0

The Drivers for the R200 and Vista are on the Epson Website. Try this link
click here
Before re-installing you need to Totally remove all previous versions not just Add/Remove programs ( look at your HD and Deleat them )
If your installing the drivers from the Website. DO NOT plug in and turn on before it tells you this may take a little while

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Best camera phone of 2015: iPhone 6 Plus vs LG G4 vs Galaxy S6 vs One M9 vs Nexus 6

IDG UK Sites

In defence of BlackBerrys

IDG UK Sites

Why we should reserve judgement on Apple ditching Helvetica in OS X/iOS for the Apple Watch's San...

IDG UK Sites

Retina 3.3GHz iMac 27in preview: Apple cuts £400 of price of Retina iMac with new model