We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Windows Help


It's free to register, to post a question or to start / join a discussion


 

Should my printer appear in Device Manager?


polymath

Likes # 0

Probably sounds a really stupid question, but it's the first time I've looked for it in Vista. (My previous OS was 98SE, so I don't know what XP's like).
I've been trying to fix my printer (can't print at all now) I uninstalled & reinstalled it, using the latest drivers downloaded from Epson. It didn't fix the problem, but I just wanted to check that it was using those drivers (and that Vista didn't install its own instead when I wasn't looking). But the printer's not in Device Manager; is this normal with Vista?
The printer's in Control Panel, but I can't find any driver details in its properties there.

Like this post
mole44

Likes # 0

Have you tries switching of the printer,unplug the USB cable.Then restat pc,Plug the USB cable back in switch on the printer and see if the pc "Finds a new device".I had a Similar problem installing an Epson printer and that did the trick for me.

Like this post
mooly

Likes # 0

You usually have to install the Epson drivers and applications in the correct order, only plugging the printer in when prompted... otherwise windows sees it as new hardware and installs it's own.

Like this post
mooly

Likes # 0

Mine shows under "imaging devices" in device manager.

Like this post
rdave13

Likes # 0

In device manager click on view and tick ' show hidden devices'. See if it's listed.

Like this post
polymath

Likes # 0

Thanks all for your suggestions!
Forgot to say it's Vista Home Premium SP2, Epson Stylus Photo PX700W (aka Epson Artisan 700). Laptop; Packard Bell Easynote BU45-P-073.

My printer wasn't amongst the hidden devices. The only imaging device shown is the built-in webcam.
The printer itself has recently been flashing its lights & saying 'general error' (telling me to switch it off again & 'consult documentation'); first occasionally (on a print command), then more & more frequently, and now on switching it on.
I managed to reset it today so it turned on without the error, then watched Device Manager while connecting the USB (I couldn't reset it with the USB already connected). 'Epson scanner' then appeared there as an unknown device (it's an all-in-one). The properties said 'no driver is necessary or has been installed for this...', (or similar vagueness). Its interface came up normally in the computer (ink levels and all), and a test page printed ok. Trying to print an email, though, put the printer back into flashing light mode.

I'm back to doing reset attempts every so often (leaving it unplugged it from the mains in between, which I gather helps with electronic things in general).

When reinstalling the drivers, I believe I did them in the right order (following advice on it somewhere). If I did reinstall them that is!
I also left connecting the USB until asked. I read of someone succeeding by waiting until the installer asked again at a later stage; so I might try that (though my printer worked ok for the 1st few months, after a straightforward installation).

I'm hoping to find it's me that's faulty, not the printer (returning things from here is a major hassle, even when the roads are passable).

Think I'll search next for any similar problems from Windows updates (SP2 looks out of the frame, with being installed 2 months before the problem started).
Might try Epson online chat support tomorrow (if they can get to work that is).

Like this post
polymath

Likes # 0

The printer isn't faulty. Long story but I've only just had the chance to try it with my desktop, where I installed it about the same time as in the notebook (with the original Epson CD). It printed ok, and showed in the imaging devices in Device Manager.
Its driver files there were 'provided by Epson' I had to take Vista's word for it, as the files have multiplied and taken different forms (mainly .dll ones, in Windows\system and Windows\twain).

With the downloaded files, I only have a rough idea of the right sequence for installing (basically, driver first, then the other things). I can't find any instructions on the Epson site for installing the downloads. And the Easy Print module, one of the downloads it shows for my printer in Vista, doesn't work with Vista according to another Epson page (so maybe I shouldn't have installed it).

Tomorrow's first thing to try looks like uninstalling the printer from the notebook again, and reinstalling with the original CD.
I'll report back, for anyone else having fun with the same printer!

Like this post
polymath

Likes # 0

Sorry - forgot to mark this resolved! I'm still struggling to get rid of the last of the old printer files before reinstalling, but the answer to my question is of course Yes.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

7 coolest 3D-printed objects: Body parts, houses, camera lenses and even pizza

IDG UK Sites

iOS 8 review: Hands on with the iOS 8 beta

IDG UK Sites

Thinking robots: The philosophy of artificial intelligence and evolving technology

IDG UK Sites

Sharknado 2 VFX: how The Asylum created CG flying man-eating sharks