We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Windows Help


It's free to register, to post a question or to start / join a discussion


 

Can't instal itunes in Win 7 professional


mercfan

Likes # 0

Thought I'd treat myself and go professional. Thought it might give me a fall back situation into XP emulator mode if s**t hit fan. The problem is , I download 64 bit iTunes it gets so far through installation and then rolls itself out again. I have trawled the iTunes help site to no avail. Cannot get into email mode to send them a help message. Any of you genii got any ideas, other thyan throw iPod away??

Like this post
john bunyan

Likes # 0

I did a clean install of W 7 Ultimate 64 bit; the i Tunes install went smoothly, and it quickly found my librarie(s).Probably worth Googling or going to the iLounge forum to get details of how to completely uninstall iTunes, then try a reinstall. No need for XP emulator mode in my case - in fact I had worse probs with XP a while ago where I had to go into safe mode to install iPod drivers. Good luck! You can create an identity in iLounge and put in questions, as here.

Like this post
john bunyan

Likes # 0

here is the website:
click here

Like this post
mercfan

Likes # 0

The problem is that iTunes appears to instal OK, will rip CDs, but as sson as I try to plug in iPod, I am informed that I must instal 64 bit version of iTunes. I have delted and installed until I can do it in my sleep, but still the same situation.
The delights of the new computer Acer Aspire z5610 all-in-one desk top. Looks great, but this iTunes issue is driving me to distraction

Like this post
john bunyan

Likes # 0

Are you sure you installed the 64 bit version of iTunes? If so I suggest telephoning your nearest Apple store - not Currys etc but Apple and they will put you through to technical support.

Like this post
mercfan

Likes # 0

I am absolutely positive about 64 bit variant. Least ways that's what it says it is when I select it. Have downloaded via IE and Firefox; makes no difference

Like this post
Aushvill

Likes # 0

y dont u just download itunes x64 again

Like this post
john bunyan

Likes # 0

I installed it with anti virus switched off. Worth a try but do ensure by looking at iLouge reccomendations that old install is gone (maybe use Revo uninstaller? I think some anti virus programmes can be a problem. Do let us know if you succeed.

Like this post
mercfan

Likes # 0

Aushvill; thank you but if you read thread you might wonder how many times I have already done so. JB; many thanks, I tried Revo uninstaller, and I am impressed with it. The bad news is: uninstalled everything, downloaded fresh copy of iTunes, removed internet connection, stopped PC Tools Internet Security, and ran installer. NO JOY. I am still awaiting any response from Acer, which annoys me. I have spoken to Apple Support on the phone, we got as far as we could before the guy gave up. We established that I do not have the Intel chipset which were giving problems earlier, but you never know, those in this machine may have inherited some of the faults.

Like this post
john bunyan

Likes # 0

Sorry , I am now at a loss but do try the iLounge forum, they sometimes have an answer.Mine works fine with W7 Ultimate plus 2200 Athlon dual core. Hope you find an answer. I asume you have "reset" the i Pod ? I did have a similar problem with a Classic on XP and it was in warranty, and Apple did something to correct it. Also with the iPod plugged in, does it show in "My computer" as a drive? I set mine in Preferences, devices to "do not auto Synch" If it shows in device manager try installing drivers by right clicking the i Pod and select update drivers..JB

Like this post
mercfan

Likes # 0

Hi JB.
I had not reset iPod, but it was not plugged in anyway. Tried to instal Modile Device Support with ipod plugged in, still no joy, but it seem to do funny things to iPod, so followed your suggestion and reset it. Still in dark; Acer have directed me to a premium rate phone line with no indication of cost ( which I thought was illegal ). tried it and found number unobtainable. Have written a letter to MD of Acer, see if that prompts any sort of response.
No panic as I tend to use iPod on airplanes, and in no rush to get on one. Will probably document this lot to editor when resolved.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Best Christmas 2014 UK tech deals, Boxing Day 2014 UK tech deals & January sales 2015 UK tech...

IDG UK Sites

Chromebooks: ready for the prime time (but not for everybody)

IDG UK Sites

Hands-on with Sony's latest smartglasses

IDG UK Sites

Apple TV setup advice: Apple TV hacks to help you create the ultimate Apple TV hub in your home