We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Windows Help


It's free to register, to post a question or to start / join a discussion


 

Only 3 out of 4 Gig RAM


john bunyan

Likes # 0

is usable. I recently installed W7 64 bit in a dual boot with XP Pro. I have installed a total of 4 gig ram, but in the "System info" it says 4 Gig installed, 3.00 usable. I have a NVidia 7800 GTX ( 256kb memory) video card also. My Motherboard is a MSI K8N SLI-F, and I have a 2.2 gigahertz AMD Athlon 64 X2 Dual core. Theoretical max RAM on motherboard is 4 Gig. Any ideas how I can get the system to use the 4 Gig? Tried max -ing the setting in msconfig ,boot, advanced - no effect.

Like this post
john bunyan

Likes # 0

Should have added the above is in the W7 64 gig boot - I realise there is a 3 Gig limit with XP

Like this post

Likes # 0

Surely you mean 3.25gb is useable? If so then you have to go into memory mapping in the BIOS and change it, i have a socket 939 DFI lan party and i cant find memory mapping so i am stuffed really

Good luck in finding it!

Like this post
john bunyan

Likes # 0

No, it says 4 Gig installed,3.0 gig usable. I thought it would, in 64 bit W7, show the installed 4 plus the video card'd 256 Kb. Will keep trying! Dont know why motherboard's spec says it will support 4 gig RAM, and W7 64 bit should be able to use it... Maybe someone else can help? Thanks for your input.

Like this post
jimv7

Likes # 0

I think you will find that because of the dual boot, windows xp is in charge and only allowing 3gb+graphic card, a clean install with windows 7 will cure the problem.

Like this post
wotbus@

Likes # 0

Is XP and W7 on the same HDD?
If so this may be the problem as jimv7 points out.

Like this post
john bunyan

Likes # 0

Thanks very much. I could not get a dual boot on master and slave to work, so I now have 3 partitions, one for W7, one for XP and a third for data. I usually , after usual virus scans etc and a defrag, clone the primary to the slave once a week, and do an image of each drive to an external HD as well, using ATI 2010. I am reasonably happy to get rid of XP now, so would it work to format that partition, as a clean reinstall is a hassle to reinstall dpwnloads etc, de register Photoshop etc.

Like this post
WaTcHiNg

Likes # 0

I have raised a similar issue in the Helproom forum. My ASUS P5VD2-X shows 4096MB installed and 2495MB usable.

I have no dual boot and have W7 64bit installed so I'm not entirely sure how whatever OS you install could affect what your BIOS tells you is installed. The BIOS runs before the OS starts surely?

Like this post
sonyboy

Likes # 0

Dual boot or Multi boot can cause the issue you have experienced ass the other guys' have said...I have just cured an issue with Memory mapping and getting full utilization of memory in 64 Bit mode myself !
After managing my remaining partitions with Acronis ...It kept "screwing " the MBR and throwing up "Boot loader " issues..I had a Multi boot setup running Windows7 ...Vista and XP...even though I decided to finally "ditch" XP ...It was the old XP partition that was on a seperate hard drive that eventually turned out to be the culprit.
After deleting XP from the partition ..I had to go into BIOS and select the Boot order screen re assign the hard disks and duly select the Hard disk that contained my Windows7! After that ...everything ran just fine..Multi boot setups can be handy..but sometimes they can throw a wobbler !

Like this post
john bunyan

Likes # 0

Hi sonyboy! As usual, you are a guru!I will shortly get rid of XP and follow your advice. I have another problem re Twain and W7 64 bit but will post another thread. By the way with your and others advice , on W7 I installed PC Tools as Firewall, Avira as anti virus and so far SAS, and C Cleaner Will Add Malawarebytes soon.JB

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Best Black Friday 2014 tech deals: Get bargains on smartphones, tablets, laptops and more

IDG UK Sites

What the Internet of Things will look like in 2015: homes will get smarter, people might get fitter

IDG UK Sites

See how Trunk's animated ad helped Ade Edmondson plug The Car Buying Service

IDG UK Sites

Yosemite tips: Complete Guide to OS X Yosemite