We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Windows Help


It's free to register, to post a question or to start / join a discussion


 

No sound since Win 7 install


ex-wirecutter

Likes # 0

Have just installed Win 7 and no sound which worked perfectly before. I did get an error message saying Win 7 was not installing certain incompatible drivers so I assume it was my sound card .Strangely I do have a speaker icon in the task bar and when I check sound properties it says the sound is working .
My sound card is on the motherboard so have tried another sound card and amplified speakers , still nothing.There doesn't seem to be any Win 7 dedicated sound cards on my local suppliers website so any suggestions please ? I have checked the plugs and temporarily connected an old hard drive with Win XP and the sound is O.K. on that.

Like this post
ex-wirecutter

Likes # 0

Further to the above I forgot to mention I have tried to update drivers but told that the best driver is already installed .

Like this post
ex-wirecutter

Likes # 0

Even further to the above , have just been on a site called Driver Robot , which claims to update all drivers . Am a bit dubious , has anybody tried them ?

Like this post
sonyboy

Likes # 0

Some bad reviews on this application from Cnet.I suggest you steer clear and try elsewhere!!
On initial install of Windows7..I too got the icon on the taskbar.
This does not mean your sound is working though..I had to install my "Realtek Audio " files from the manufacturers website in order to get the sound correctly installed!
Have you tried to locate an updated driver from your soundcard as this seems to be a driver related issue ..What is the type of card you have for audio on your mobo? Might help someone throw a little light on your issue !

Like this post
rdave13

Likes # 0

Try start and in the search bar type system. Click on system information. Expand components- sound device. Mine shows Realtek AC'97 audio. At bottom of list it shows driver version as 6.0.1.6305
Searching for this gets me to here; click here
Check your sound device to see if you can search for the right driver.

Like this post
rdave13

Likes # 0

The link goes back to the agreement window but accepting this and the Vista/ Windows 7 driver is there.

Like this post
pa1916

Likes # 0

In sound is it set to speakers or digital??
If it is speakerstry digital.
I had a 4 year old Novertech desk top with Realtek
onboard sound had to give up on that and bought a sound card no problems after that.

Like this post
pa1916

Likes # 0

Sorry for space error should have read speaker try.

Like this post
ex-wirecutter

Likes # 0

Many thanks for all your suggestions will try them and see what happens . By the way sound is Realtek AC'97 and I have downloaded their supposedly Windows7 driver but that just put another speaker icon with volume control on my taskbar which didn't help .

Like this post
ex-wirecutter

Likes # 0

Update , Have now downloaded an updated driver from Realtek , but , when I try to install it Windows security stops the installation saying it is unable to verify the driver . When I click "install anyway"
it refuses . Looks like I will have to try the new sound card option . So much for the "Windows 7
PC Simplified" claim.

Like this post
sonyboy

Likes # 0

Sorry to hear you are still having difficulties.
The best driver I found was the Realtek driver Version 6.0.1.5936 which is not digitally signed but installed without any problem on my machine.

Is it the UAC which is preventing your install?
I "took ownership" of the file and had no problems at all.The installation placed the extra "brown loudspeaker icon" which a "mouse hover" will show as "Realtek HD audio Manager"...From here you can set up your sound configuration! Hope this helps ?

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Motorola Moto G vs Nokia Lumia 530 comparison: What's the best budget smartphone

IDG UK Sites

Everything you need to know about Apple's iPhone Camera in iOS 8

IDG UK Sites

Why you shouldn't trust password managers

IDG UK Sites

How to make an 'Apple iWatch' using an iPod nano and a 3D printer