We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Windows Help


It's free to register, to post a question or to start / join a discussion


 

Have you downloaded the Release Candidate?


Forum Editor

Likes # 0

If you have, how did the installation go - was it smoother than a smooth thing in a smooth shop, or did the installer start looping, and run through the process again? Several people seem to have experienced this problem.

Like this post
nikef

Likes # 0

Download took 12 hours

installed in 20 mins today ,everything is working great ,had a problem with the realtec drivers,but windows managed to instal the drivers after the install.

Like this post
MikeHut

Likes # 0

Installation was fine but I am now getting a nag telling me Windows is not genuine and giving a link but the link goes to a search page with no information ! I downloaded this normally and used the correct registration code.

Like this post
rawprawn

Likes # 0

Downbloaded and installed on partition to duel boot.
No problems whatsoever, and I like it. I had difficulties using IE 8 in Vista, but in Windows 7 it is a different animal altogether.

Like this post
daxian

Likes # 0

hi i got the 64bit rc1 ....
went in, no problem, about 20 mins ..
only two devices not recognised were gameport and midi ,drivers not available from asus as yet.
overall a problem free install !!!!Dave.

Like this post
nikef

Likes # 0

just noticed that all my usb ports are not working,any1 else have this problem,if so do you know a fix ?

Like this post
Why wont it work

Likes # 0

Just installed the 32 bit version. Only took 1 hours to download, was going just short of 1mb/s download. It took twice to install it, the first time it encountered some kind of problem, but the second time it installed after about 50 mins.

It seems to run really quite well, although there are a few things according to device manager which haven't been installed and which it can't find a driver for... such as a serial port.. even though the pc doesn't have one... hmm

Anyway, it's much quicker than Vista was on this laptop, must boot a few times quicker easily, even with everything installed. Running a lowly Core2 Duo U7600 1.2ghz, 2gb, 80gb HDD.

Like this post
Strawballs

Likes # 0

click here Thought this would be quicker than repeating everything

Like this post
Strawballs

Likes # 0

Any body else installed Norton 360 on it having trouble with drivers being blocked

Like this post
David-293504

Likes # 0

downloaded in about 2hrs
installed first time no probs
installed on separate partition to my trusted xp
found all my devices no driver probs
tried to dual boot using acronis disk director but it doesn't recognize win 7
found this site to help will try again soon
click here

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Best Christmas 2014 UK tech deals, Boxing Day 2014 UK tech deals & January sales 2015 UK tech...

IDG UK Sites

LED vs Halogen: Why now could be the right time to invest in LED bulbs

IDG UK Sites

Christmas' best ads: See great festive spots studios have created to promote themselves and clients

IDG UK Sites

Why Apple shouldn't be blamed for exploitation in China and Indonesia