We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Windows Help


It's free to register, to post a question or to start / join a discussion


 

Sleep button in Vista not puting PC to sleep


tufti

Likes # 0

In the past when I pressed the sleep button on my keyboard the PC would shut down and the power light would flash on and off.
The monitor would also shut down and go to power save mode.

Now for some reason only the monitor goes to sleep and the PC keeps running.

Did a search but couldn't find anything similar.

Anyone had the same problem?

Thanks, Tufti

Like this post
mocha

Likes # 0

Hi tufti,

Go to Control Panel>Power Options>Choose What The Power Buttons Do. and make sure that the action for 'When I press the sleep button:' is set to sleep for both 'On battery' and 'Plugged in'. Next Go to Control Panel>Power Options>Change when computer sleeps>Change advanced power settings. and make sure the power plan that your computer is running at the time eg. High Performance (Active).>Power buttons and Lid>Sleep button action. Has 'on battery' sleep and 'plugged in' sleep set for your computers ACTIVE power plan.

Like this post
tufti

Likes # 0

Mocha, thanks for the reply, I should have said it's a PC that i'm having a problem with but I checked the settings you mentioned and even set the power button to standby.
This results in the monitor going to standby but the PC keeps running on :-)
A few weeks ago I did a complete install of Vista and updates including SP1 and I tried the sleep option after this and it worked.
However after installing all my programs etc it now doesn't so I guess it's one of those that's causing the problem.
I did have a go at Windows 7 beta the other day as an update and strangely it brought the sleep action back. I have now restored to original Vista using Acronis and I guess I can live with the sleep problem for now.
Thanks again
Tufti

Like this post
tufti

Likes # 0

Having played around with various "Power Plan" settings I discovered that by choosing "Balanced" and "Change Plan Settings" to "Turn off display never" and "Put computer to sleep never" the sleep button works and both PC and display go to standby and resume when keyboard used or mouse moved.

This may be of use to others.
T

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Best Christmas 2014 UK tech deals, Boxing Day 2014 UK tech deals & January sales 2015 UK tech...

IDG UK Sites

Apple's 2014 highlights: the most significant Apple news of 2014

IDG UK Sites

2015 creative trends: 20 leading designers & artists reveal the biggest influences & changes coming)......

IDG UK Sites

Ultimate iOS 8 Tips: 35 awesome and advanced tips for using iOS 8 on iPhone and iPad