We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Windows Help


It's free to register, to post a question or to start / join a discussion


 

USB Hard Drive not seen in Vista (was working)


Was Bike Bloke

Likes # 0

USB Hard Drive not seen in Vista (was working)

I have a problem with my LaCie USB hard drive running with Vista on a Dell Inspiron 9400.
It's been fine until last week and now is no longer listed in explorer, Device Manager or Disk Manager. The Laptop (Dell Inspiron 9400) chimes when it's connected/disconected but shows nothing.
It works fine on an XP laptop.
I finally used the XP Laptop to reformat it but that didn't help. I tried the 'delete infcache' solution listed elsewhere....nothing.
Tried deleting USB and drive files in Device Manager....nothing.
Tried various registry repair tools....nothing.
Tried emailing LaCie for help....they didn't bother replying!
Anyone got any new ideas????

Like this post
gazzaho

Likes # 0

It might be worth checking if you intalled an optional update from Vista Update called Cypress - Other Hardware - Cypress AT2LP (3.03.0000.2). This update stopped one of my drives from working similar to your problem. The only way to get my system to recognise my drive was to do a System restore to before the update was installed.

I've read that it can be uninstalled from the device manager but the update never showed up on my system anywhere after installation, the only way for me was the restore option.

Like this post
m.hazelton@live.

Likes # 0

Thanks Gazzaho but I can't to a system restor. tried several times but fails every time. Couldn't find the Cyprus update either.
Thanks for trying.
be well

Like this post
igk

Likes # 0

I had the same problem recently with a usb pendrive and found the cause was I had disabled the autorun feature you could check to see if this is the problem,go to control panel,programes,default programes,change autoply settings and ensure there is a tick in "use autoplay for all media and devices"
As soon as I did this all was ok.
Hope this helps.

Like this post
m.hazelton@live.

Likes # 0

The Cyprus solution worked. Found the update in the Device manager under USB drivers. Deleted it and all OK.
Thanks all

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

The best iPhone 6 alternatives: Price and specs compared with the best smartphones

IDG UK Sites

The top 10 Apple products ranked by pixel density: Which Apple devices have the sharpest screens?

IDG UK Sites

SBTRKT's Look Away webcam-based interactive music video won't keep your gaze

IDG UK Sites

Retina MacBook Air release date rumours and specs: Gold 12in Retina MacBook Air almost 1cm thinner...