We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Windows Help


It's free to register, to post a question or to start / join a discussion


 

Epson SX 105 - Vista driver problem


Docking Bay 94

Likes # 0

I have an Epson SX105 printer/scanner and have downloaded the correct drivers from Epson UK.

After installing the software the drivers are not being installed correctly in Device Manager. During the printer installation it gives me the option to choose a port manually but a USB port is not listed.

The Epson site support is down today but seems really unhelpful when it does work.

Has anybody managed to get the above printer working with Vista or had the same problem?

Like this post
Woolwell

Likes # 0

Are you using Vista 32 bit or 64 bit?
The Epson support site is available for me.

I don't have an SX105 but it is a fairly recent model and should have come with the required software/drivers on the CD. It is important to follow the correct order of installation on the guide which tells you to not connect the uSB cable until the software teklls you to.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Samsung Galaxy Alpha vs iPhone 5S comparison review: Metal smartphones fight

IDG UK Sites

Gateway to your kingdom: why everybody should check and update their broadband router

IDG UK Sites

Fonts review

IDG UK Sites

Best Mac? Complete Apple Mac buyers guide for 2014