We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Beta Testing


It's free to register, to post a question or to start / join a discussion


 

Welcome


Forum Editor

Likes # 0

to the Norton 360 beta forum. If you're one of our team of beta testers you should by now have the test software safely installed on your computer from the download link I sent you recently.

As soon as you have Norton 360 running on your machine please post in this thread to tell us how your download and installation went. We're keen to know about any difficulties before we proceed further.

Please don't start new threads of your own - it will confuse the process. Once everyone has reported on a successful (or otherwise) installation we'll move on in a new thread.

Like this post
Forum Editor

Likes # 0

Congratulations on being the first arrival, I hope you'll soon be joined by the others. Emails have, or are going out with news of the publication of the forum, but I imagine that others will, like you, find it by themselves.

Like this post
justme

Likes # 0

The download was straight forward and reasonably fast.

The installation required me to uninstall AVG free 8.0. I know that we should not run two antivirus programs at the same time but I would have preferred to keep the AVG so that I could run it if I wanted a second opinion.

For some strange reason I was sent two e-mails from Norton with two different product keys. One did not work but the other did.

Like this post
perpetual motion

Likes # 0

Whitetruckman i had the same issue what u need to do is open another browser when u click on the link then copy the link & paste it in another browser or the same but without all the foobar before the "WWW" bit it then takes u to the correct destination..

Like this post
Forum Editor

Likes # 0

Yes, the address was an mhtml document - the same one you obviously received. Let's move on from that - the main thing is that you now have the software. Perhaps you'll update us when you have it installed and running.

Like this post
perpetual motion

Likes # 0

my installation was great np's at all the only thing i didnt like is it installed a toolbar without asking me..? or did i miss something..?

Like this post
perpetual motion

Likes # 0

yeah im in now...whats next people..?

Like this post
WhiteTruckMan

Likes # 0

These things happen. But as long as you are aware of the hiccup (thats all it is really) and I have in fact downloaded the correct version then all is well.

Just for my own curiosity though, when you got the address not valid page in IE did you happen to check out what was in the address bar?

WTM

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

OnePlus Two release date rumours: Something's happening on 22 July

IDG UK Sites

13in MacBook Air review, Apple's MacBook Air 2014 reviewed

IDG UK Sites

5 reasons to buy an electric car and 5 reasons not to

IDG UK Sites

Just graduated? Learn all you need to know to kickstart your career in our Creative Graduate Guide