We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Games


It's free to register, to post a question or to start / join a discussion


 

games wont play


threelegs
Resolved

Likes # 0

I wonder if you have any ideas on the following problem?

I built a PC early this year. E7600 core 2 Duo @ 3.06ghz It has a Asrock P43DE M/B Gigabyte GeForce 8400GS Graphics card 2 GB DDR2 Memory XP Pro.

The PC runs perfectly smooth, no problems until I try to play a game. (Oblivion, Tomb Raider Underworld/Anniversary, Jack Keane etc) They load no problem but when I click on play they just crash to the desktop or just do nothing at all.

I have been seaching for answers for this such as. Contacting the games people, they suggest the graphic card is faulty so I bought another one of a different manufacturer, but I have the same problem. They then suggested contacting NVidia. They told me to update the driver, no luck. Then install an older driver, no luck. Use Driver Sweeper, no luck. They then gave up with an apology saying they could not help any further. I have tried contacting the M/B people but do not get a reply. I updated Active X. Then in a last desperate attempt I replaced the hard drive and reinstalled two versions of XP in case the reg was corrupt. I did not install any other programs eacept the games, STILL NO LUCK. I checked the BIOS and all I could see there was that it had PCI selected, so I changed it to PCI E,I thought I had cracked it, no such luck. All my other programs run without a blink. I have also ran BurnIn Test Tool on memory and graphics and came up with no problems.

Like this post
threelegs

Likes # 0

There are no yellow/red icons in device manager. Other devices connected to PC are, Cambridge soundworks audio via audio outs, USB's are 2 printers, 1 ext HD, 1 TV reciever and 1 weather station, LAN cable and KVM switch for 3 PC's. The other PC's are too old to play the games although one does try but the graphics are very slow as it has onboard graphics and is not worth upgrading. Keyboard is a Microsoft Multimedia Keyboard 1.0A and a Microsoft wireless optical mouse 2.0. These I can swap when I get my hands on altrnatives from friends etc if you think This could be the problem. How come this does not affect Penumbra game.

Like this post
gengiscant

Likes # 1

Penumbra is not really a graphic intensive game. Yes it is worth trying an alternative to your mouse/keyboard. At the moment what we are trying to do is eliminate possible causes no matter how odd they might seem.''DirectInput' I believe is the cause of your gaming problems. So what you have attached to your PC will have some bearing. Silly question but you did install all your motherboard drivers when you installed XP?

By the way if you like Penumbra, then have a look at this.http://www.amnesiagame.com/#main

Like this post
mrwoowoo

Likes # 0

Sorry to butt in , but a few thoughts. Have you plugged your monitor into the motherboard by mistake (onboard graphics) instead of into the graphics card? Sounds silly, but i did it once when moving my PC. (yes, i am silly). It would explain why no games run. Have you overclocked your PC at all? If so, the graphics card should be limited to 100 mhz in the bios. Is your PSU faulty or not up to the task?

Like this post
mrwoowoo

Likes # 0

You could try to disable your sound hardware devices in device manager to rule out a compatability problem with it.

Like this post
threelegs

Likes # 0

I don't know how to say this but "YIPPEEE", all the games now work.Doesn't Lara look good these days, I haven't seen he for ages. How does something so simple cause so much frustration. It was the weather station where I can download the stats to the PC. When I unplugged it the DxDiag error disappeared and the games played. But when I plugged it back in the error re-appeared and the games once again would not play. How come the games, memory and graphic people could not spot this? Thanks for your input mrwoowoo but I did not get as far as trying out your ideas. BUT A BIG THANK YOU GOES TO GENKISCANT, I was all but giving up till you came along and in less than a week you have it solved. I hope I haven't put a jinx on it by saying YIPPEEE. I shall have to have a look at amnesiagame, I also enjoyed playing "City of Fog" for the short time, I may have to buy it now. But at the moment I have a date with Lara. So once again Genkiscant thank you, thank you, thank you.

Like this post
gengiscant

Likes # 0

Glad to have been of some small help,I only showed you the path. Please put a tick right hand side,it should go green.Problem solve indication.

Like this post  
threelegs

Likes # 0

You were of a big help, don't underestimate the ammount of help you gave me. Many Thanks once again.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Samsung Galaxy Alpha vs iPhone 5S comparison review: Metal smartphones fight

IDG UK Sites

Gateway to your kingdom: why everybody should check and update their broadband router

IDG UK Sites

Fonts review

IDG UK Sites

Best Mac? Complete Apple Mac buyers guide for 2014