We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
 
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Windows Vista Help


It's free to register, to post a question or to start / join a discussion


 

Wireless adapter shown but no connection


johndap

Likes # 0

Hi I have rescued an Advent laptop from the dead. Initially I loaded Linux on which I was able to use the built in wireless connection. I have since reinstalled Vista (not from the original installation disc) and I cannot get the wireless connection to work. Device Manager shows '802.11g Mini Card Wireless Adapter' and I have searched for an up to date driver which I am assured I have. However 'Connect to a network'only shows the PPPoE connection. I have looked in vain on line for an answer. Help please.

John

Like this post
difarn

Likes # 0

Have you tried connecting by ethernet cable first?

Have you made sure that you are not using the correct protocol - is ipv6 unchecked, is the pc set to obtain an IP address automatically- see this article.

Have you checked that you do not have a proxy set?

Tools -> Internet Options -> Connections -> LAN Settings -> UNCHECK ALL BOXES HERE

Have you tried renewing your TCP/IP Protocol and Winsock - steps shown in this article if you haven't.

Like this post
johndap

Likes # 0

Yes I have an internet connection through an ethernet cable, that is working fine. I have reset Winsock. All LAN Setting boxes are unchecked. To my simple mind the fact that I have an internet connection thro' cable suggests the IP Address and Protocol is correct? How do I get to ipv6?

Like this post
difarn

Likes # 0

  1. Go to Control panel.

  2. Go to Network and Sharing Centre.

  3. Connection click on view status, then Properties.

  4. Untick IPV6.

  5. Click OK.

Like this post
difarn

Likes # 0

Just a thought, do you have the latest service pack for Vista - this article from Microsoft Support will help you with this.

Like this post
johndap

Likes # 0

Thanks for your reply.

I found ipv6 and unchecked it - no difference.

Checking out the Microsoft link it says it is correcting the following scenario: 'you can see that a wireless network is available in the Connect to a Network dialog box.....' and do not download a fix unless you are solving that problem. But that is just the point I have no wireless connection in that box. If I go to the 802.11g Mini Card Adapter properties it says the device is working properly! The wireless switch on the front is on of course. I've got a feeling I'm stuffed on this.

Like this post
difarn

Likes # 0

In device manager do you have any other wireless network adapter listed other than a Mini Card (or is it Port) adapter? If so this is the one that you should be checking to see if the driver is updated. When you re-installed Vista did you also install the service packs 1 and 2?

When you were setting up the wireless did you go to..

start-control panel - network and sharing centre - select set up a connection or network - select manually connect to a network - click next - enter the information required and put a tick in the "start this connection automatically" box - click next - choose "use the existing network" - at this stage you should see the available networks click on connect - you may have to enter the password here.

Like this post
mole1944

Likes # 0

had the same problem with an advent it just cleared itself still no idea why,and that was after many reistalls of Vista,i did get a cheap dongle from Amazon and that did the trick before all righted itself

Like this post
johndap

Likes # 0

In 'Network adapters' there is only one Wireless Adapter.

I haven't installed Service Packs 1 and 2 subsequent to the Vista reinstallation. Whether they were on the disc I bought I wouldn't know but hopefully I can find out (during office hours - Mon-Fri). Can I find out from the computer what version is installed? I am able to use our local network (through the ethernet cable) and can print through my desktop. Surely this means I have the network setup. Can anyone say if when the wireless on/off switch on the front is set to off whether the wireless connection still appears in the 'Connect to a network' box?

Like this post
difarn

Likes # 0

This is how you find out which SP is installed.

If the wifi is not enabled then you won't be able to see a wireless network to connect to.

Have you tried going into device manager, right-clicking on your wireless adapter, clicking on properties - advanced to see if there is a box that should be unchecked in relation to wireless device off.

Do you have any function keys that turn wifi on and off? Some Advent use Fn +F1 which you should hold down simultaneously and others have to do this via software such as the Intel Utilities that is usually in the start menu. Failing this it can be enabled through device manager as explained earlier. If this works then you should see a light - usually on an Advent this is to the far left.

Like this post
difarn

Likes # 0

As an afterthought - different Advent models have different function keys allocated for turning wifi on and off - you could google your model to see if you can find the correct combination - I have read posts that say Fn +F1, Fn + F2 and Fn +F10.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

LG G Watch release date, price and specs: Hands-on and pictures

IDG UK Sites

Apple financial results: iPhones, iPads & Macs sales for Apple's Q2 2014, plus shares to split

IDG UK Sites

Twitter - not news

IDG UK Sites

See Moo Studios' new animated advert for Blue Moon beer