We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
 
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Networking Help


It's free to register, to post a question or to start / join a discussion


 

After removing malware XP can't get IP address


bfoc

Likes # 0

A friend had problems with their XP (SP 3) machine and asked me to check it. I used a Kaspersky Linux based bootable CD to check their machine. It found and cleaned a large amount of malware.

The machine works fine now but it is unable to get an IP address to allow it to connect to the internet. This happens with both a wireless and wired connection and isn't hardware related as the Linux based Kaspersky CD can download updates.

I have tried releasing all IP addresses and flushing the DNS cache, all to no avail. I also cannot access Windows Firewall. The friends cannot locate their XP CD – if they had one.

Any suggestions?

Like this post
bfoc

Likes # 0

However this was suggested earlier in the thread and I have tried both steps but to no avail.

I'm guessing something has been corrupted/removed that is needed by Windows. Problem is I'm not sure what.

Like this post
mgmcc

Likes # 0

Try *reinstalling* TCP/IP in Windows XP:

In the Network Connections folder, right click the network connection and select Properties. Click the "Install" button, select Protocol and click the "Add" button. In the next box (don't select TCP/IP version 6), click the "Have Disk" button and, in the line "Copy manufacturer's files from:", type C:\Windows\inf and click OK. In the next box, click Microsoft in the left pane, then "Internet Protocol (TCP/IP)" in the right pane and click "OK". Close all open windows and reboot the PC.

Like this post
bfoc

Likes # 0

I have just done that but once more to no avail - the connection is stuck at 'Acquiring Network Address'.

I tried doing an ipconfig /release and got the message that the IP Address "has already been released" and when I did an ipconfig /renew got the message:

"An error occurred while renewing interface Local Area Connection 4: The RPC server is unavailable"

Like this post
mgmcc

Likes # 0

Have you tried allocating a fixed IP address?

Like this post
bfoc

Likes # 0

I have tried that with two separate IP addresses.

I will try again.

Fast running out of enthusiasm!

Many, many thanks for the help.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Samsung Galaxy Note 4 release date, price and specs 2014

IDG UK Sites

iOS 8 features wishlist: the changes iPhone and iPad users want in Apple's iOS 8

IDG UK Sites

25 Years of the World Wide Web: Happy Birthday, Intenet

IDG UK Sites

Developers get access to more Sony camera features