We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Google Chrome now very slow to load


stlucia2
Resolved

Likes # 0

I'm using Windows XP fully updated, and I started using Chrome some months ago because of issues with IE7. Recently Chrome has been updated, and now displays on its Google home screen eight large thumbnails of sites I've recently visited. At the same time its initial loading has slowed down significantly, and it even locks up if I try to start using it before it's finished loading fully.

I've looked at the settings to try and find a way to disable the thumbnails, in the hope that this will speed up the loading, but can't find anything. In fact, I realise now that I don't even need to use the Google Search screen as my home page because Chrome's address bar doubles as a Google search bar. So how can I achieve a blank home page, so it doesn't waste time loading history?

Like this post
Jock1e

Likes # 0

Latest chrome update is version 30.0.1599.69 not sure if that is the version that you have.

Click Here

Like this post
stlucia2

Likes # 0

Yes, that's my version Jock1e.

Thinking about it a bit more, I have two choices but can't find either one in the setup menus: One is to change my Chrome home page to something other than Google -- perhaps even a blank page; the other is to configure the Google page so that it doesn't show the recent history thumbnails. That's on the assumption that it's the thumbnails that are slowing things down.

Like this post
alanrwood

Likes # 0

Todo that go into Chrome settings and set the home page to "about:blank". That will give a blank log on page but those stupid links will still appear on any new tabs.

Like this post
stlucia2

Likes # 0

I've gone into settings (in the drop-down menu that appears when clicking on the three horizontal bars at the top right of the screen), but there's no option for setting the home page -- I can only find an option for setting the home button, and changing that, or disabling it, doesn't make any difference.

Like this post
Batch

Likes # 0

to set home page as about:blank

Go to Settings

2nd item down screen should be "On Start-up"

Select Open a specific page.....

Click Set Pages

For Add A New Page, in the box enter: about:blank

Click OK and exit Settings

Like this post  
Batch

Likes # 0

you could also try clearing your browsing history to speed things up

Start Chrome

hit CTL+SHIFT+DEL at the same time

in the box that comes up I do the following:

Obliterate the following items from: The beginning of time

And I have ALL of the boxes checked.

You may choose not to be so severe - it's your choice.

Like this post
spuds

Likes # 0

If Google Chrome is beginning to get slower, then perhaps do a Start-Up check with CCleaner (if installed), and see if that finds anything. CCleaner wil also check all other browser Start-Up and perhaps running problems?.

Like this post
stlucia2

Likes # 0

Thanks for the walk-through Batch. I've in fact set my home page to Google.co.uk, which is what I'm used to. Startup is back to normal now.

Before I changed it, the page listed was Google.co.uk but with a / and a long string after it; thinking back, I remember now that a recent ZA update forced me to make ZA the default browser, and I think that's when things started to go wrong.

I'd already used Chrome to clear all history. I use CC to clean up and check for issues quite regularly.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

6 cheapest 4K TVs in the UK 2014: Get a UHD telly without breaking the bank

IDG UK Sites

Apple MacBook Air (11-inch, 256GB, Early 2014) lab tests and benchmarks

IDG UK Sites

How to stop your parents opening and responding to phishing emails

IDG UK Sites

Google to ship first Project Ara developer boards in July