We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Windows 7 shut down


jerica

Likes # 0

Hi, wierd thing happening to my computer, tried to shut down win7 ultimate and it gets to the shut down page and just sits there, no key response or mouse. After about 20 mins I tried a reboot and it says it's starting and then the screen goes blank and nothing. Switched it of at the mains and on again and it says as there was a problem starting do I want to do a start up check, I did that and it says it cannot solve the problem. I reboot again and all is well. That lasted for two days but now it is doing it again. Help please.

Like this post
john bunyan

Likes # 0

I would go to the Start menu, All Programmes, Accessories, Command prompt. (Right click - select run as administrator0. Then in the black bit type in sfc /scannow and let it run ; it will take a while. It should repair any little glitches.

Like this post
Chronos the 2nd

Likes # 0

It may well be a program you have installed that does not want to shut down correctly. So check any recent additions.

Like this post
Procrastinus

Likes # 0

Agree with all above. However MS default settings for shutdown are odd!

Start>type in regedit>HKEYLOCALMACHINE>SYSTEM>CurrentControlSet. Right click on Control and look at WaitToKillServiceTimeout. The setting can be very high, i.e. 20000. You can safely set it to 200 by right clicking on it, and this will speed up shutdowns.
If you don't like it you can always revert!

Works well on all my XP and Win7 machines.

Like this post
lotvic

Likes # 0

Agree with 608, several years ago I altered my WaitToKillServiceTimeout to 200 (XP) as shutdown was hanging.

Like this post
jerica

Likes # 0

Thanks for all the advice, tried 1 and checked 2 and did two different virus scans and it's been OK for two days, fingers crossed. Might try the Wait to kill thing as well as both of my OS's seem to hang more than they should.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Best Christmas 2014 UK tech deals, Boxing Day 2014 UK tech deals & January sales 2015 UK tech...

IDG UK Sites

Chromebooks: ready for the prime time (but not for everybody)

IDG UK Sites

Hands-on with Sony's latest smartglasses

IDG UK Sites

The 13 most inspirational Tim Cook quotes