We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Caps lock on all the time and selecting all programmes from, desktop


Eileanbeag

Likes # 0

My son has Dell Dimension computer running Windows Vista. He has recently had problems in that when he uses Word it appears that the Caps lock is on all the time. When he comes out of this and goes to his desktop if he tries to select another programme all the programmes on the desktop are highlighted. He runs Norton and it is not showing any problems. He has tried System restore and restore last known good configuration with no avail. Is this a virus and if so what caan be done.

Like this post
Ian in Northampton

Likes # 0

This may be a stupid question, but I've got to ask it... He does know how to turn caps lock off, right? If he's tried this and it still doesn't work, your description of the symptoms makes me think that there's something wrong with the caps lock key that's making the keyboard think it's being pressed. (I say that because, if you click on an item and then click on another item with the shift key pressed, the PC will select all the items between the two items clicked on - which is what seems to be happening when he clicks on shortcuts on the desktop.)

Like this post
Ian in Northampton

Likes # 0

By the way: for those of you who aren't touch typists, and who look at the keyboard all the time when you're typing - only to find out when you look at the screen that you've accidentally had the caps lock key on - I can't recommend 'Boldfinger' highly enough. It's hugely increased my productivity...

Like this post
lotvic

Likes # 0

It sounds to me as if one of the shift keys is stuck down. This could be due to crumbs, muck etc in the keyboard. Pick keyboard up and turn it upside down and tap and shake (gently) to dislodge crud. This is best done when pc is switched off.

Like this post
Eileanbeag

Likes # 0

No its not the keyboard as He has changed this top test it - which makes me think it is a virus

Like this post
Russ57

Likes # 0

He may have accidentally pressed Ctrl/shift/A. This toggles between caps on and off. Try pressing them again to see if it clears it.

Like this post
Ian in Northampton

Likes # 0

Like this post
lotvic

Likes # 0

Ian in Northampton, wish you'd warned us about the loud music ;P

Like this post
rdave13

Likes # 0

In Windows 8, control panel, language, advanced settings, change language bar hotkeys, in the pane that opens check that , under advanced key settings, the button is dotted for 'Press the CAPS LOCK key' for turning off Caps Lock and not the SHIFT key. Might be the problem. In Win 7, Control Panel, Regional and Language Options, Keyboards & Languages, Change Keyboard, Advanced Key Settings.

Like this post
Ian in Northampton

Likes # 0

lotvic: sorry - I only rarely have my speakers turned on... :-(

Like this post
lotvic

Likes # 0

Ian in Northampton, me too, and I'd forgotten they were on LOL

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Best Christmas 2014 UK tech deals, Boxing Day 2014 UK tech deals & January sales 2015 UK tech...

IDG UK Sites

LED vs Halogen: Why now could be the right time to invest in LED bulbs

IDG UK Sites

Christmas' best ads: See great festive spots studios have created to promote themselves and clients

IDG UK Sites

Why Apple shouldn't be blamed for exploitation in China and Indonesia