We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

setting up a third party smtp with Sky


silverfoxx

Likes # 0

My e-mail provider is a company called Firenet. I have just signed up with Sky and I want to keep my e-mail address with Firenet. The third party smtp settings that Sky gave me - smtp.tools.sky.com and port number 465 - don't work. Sky don't seem to know why it doesn't work and don't seem able to suggest what to do to make it work. I've tried all the permutations including Sky username and password and nothing seems to work. Does anybody have any ideas ? I can receive e-mails but can't send any. I don't want to set up a new e-mail address as this would cause a lot of problems as I'm self employed. thanks

Like this post
lotvic

Likes # 0

I have a vague recollection that you have to alter a setting/tick a box/register the 3rd party email on your account on the web mail server to allow it. Might be this bit 'Sign in to Sky mail go to settings>Forwarding Imap/pop>enable pop and or Imap' (sorry to be so vague, but a search on sky forum might throw up more info)

Like this post
Woolwell

Likes # 0

Try using the firenet settings instead firenet. It is worth a try but Sky may block the smtp.

Like this post
Batch

Likes # 0

By way of background (just in case you are not already aware of this), in using a "3rd party" SMTP service one could (should be able to) send an email from any email address (i.e. even a made up one). All that happens is the SMTP server dumbly passes the email out in to the outside world. Sometimes the SMTP servers do some checks (such as whether the domain used in the senders email address is valid).

So all you need to do is get past whatever is blocking your outbound use. I use a similar approach as you (but with PlusNet) for several old email addresses without problem.

The port 465 that you refer to suggests that Sky require you to use SSL to connect securely (i.e. using encryption) to their SMTP server (so presumably you have the same setting for any supplied Sky email addresses?)

The other main consideration is whether the Sky SMTP server requires authentication (not to be confused with a secure connection to the SMTP server). If authentication is required you need to set your email client settings (specifically the outgoing mail server) for the firenet email account concerned but using your Sky mail login details.

Like this post
lotvic

Likes # 0

Apparently it gets more complicated as Sky have moved (from Gmail servers) their email over to Yahoo Servers this month (April 2013) Sky Yahoo! Mail switchover issues update

Like this post
Forum Editor

Likes # 0

Most ISPs now require you to authenticate to their SMTP servers. They want to be sure that they can easily trace spam sources.

As Batch correctly states, SKY will require you to use an SSL encrypted connection to the smtp.tools.sky.com server, so you must tick that option when you configure the mail account in your email software. You must also tick the option to authenticate to the server. This will require you to enter a SKY username and password.

Like this post
silverfoxx

Likes # 0

thanks to all those who responded to my querie. The solution was as follows - once I had set up a Sky e-mail account and added my own e-mail address to it, I was sent a verification. After answering the verification, I checked my Firenet settings on Windows Mail and made sure that they hadn't changed including the port numbers. I didn't use the Sky smtp settings and once the verification was answered, everything jumped into place. It took a long time to get there but a chap at Sky went the extra mile for me in getting this resolved.

Like this post
lotvic

Likes # 0

Thanks for posting the solution, it will help others with same problem.

If you think it's sorted, you can close this thread by clicking on one of the big grey ticks at the right of any post (your own that gives the final solution :)) and it will turn green. When page is refreshed the Thread will be marked 'Resolved' (Can also be Unticked by reverse - click on green tick and it will turn grey, etc)

Like this post
Batch

Likes # 0

It sounds like firenet are "happy" for you to still access their SMTP servers even though you are no longer using them as ISP . Relatively unusual I think - although similar to the way it works with the likes gmail and gmx work in that you can access their SMTP servers from anywhere [although in those cases you can certainly only send email where the sender address is from one of their respective domains].

Although slightly different, I recall now that, with BT (as ISP), to send "foreign" email thru their SMTP servers, one has to go thru a verification process first (I had to set this up for a neighbour once) AND, I believe that SKY take a similar approach. AFAIK, most ISP's are more relaxed and don't require such verification and just allow one to send anything out over their servers (from your logged in internet connection).

Anyhow, good that you are all sorted.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Exclusive: Samsung exits laptop market including Chromebooks

IDG UK Sites

Is Apple losing confidence in itself?

IDG UK Sites

How a London VFX studio is ditching desktop workstations for cloud-based creative power

IDG UK Sites

iOS 8 tips & tricks: Get to know iOS 8's handy new features