We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Can't disable Asus Touchpad


subi

Likes # 0

Asus P52F, O.S. 7 Professional. Had problems with hard drive which was replaced and new Windows 7 installed. All Asus references were removed. I use a Microsoft Wheel Mouse Optical instead of the Touchpad. I have found that the pad is so sensitive that when I type emails, word files, etc. that the letters jump about. I have tried to disable the Touchpad via the Mouse settings, also Fn + F9 but nothing works. there is no reference to the Touchpad in Device Manager also, so I can't disable the driver! Help please....this has taken a long time to type as the letters are jumping about!

Like this post
Woolwell

Likes # 1

I think that your problem may be because you haven't installed the Elantech Touchpad driver. It can be downloaded from Asus support

Like this post
Woolwell

Likes # 0

In Device Manager it should be under Mice and other pointing devices.

Like this post
Woolwell

Likes # 0

Your manual gives instructions:

Windows - Control Panel - Hardware and Sound - Mouse Click ELAN on the top and check disable when external usb mouse plugged in.

However I do wonder if your problem is associated with the fact that you may not have any of the ASUS software installed.

Like this post
subi

Likes # 0

Woolwell....I think you are correct in saying it may be the lack of the Asus software. If I open the Mouse tab it reads Buttons, Pointers, Pointer, Options, Wheel and Hardware. Opening Hardware gives me two entries Microsoft PS/2 Mouse and Microsoft USB Wheel Mouse Optical. No sign of Elan as there should be.

I have checked on some software called Touchfreeze which is supposed to disable the Touchpad while typing. That may be one way of eliminating this problem. Anyone used Touchfreeze?

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Nexus 6 vs Sony Xperia Z3 comparison: Lollipop phablet takes on KitKat flagship smartphone

IDG UK Sites

Why people aren't upgrading to iOS 8: new features are for power users, not the average Joe

IDG UK Sites

Free rocket & space sounds: NASA launches archive of interstellar audio on SoundCloud

IDG UK Sites

iPad Air 2 review: Insanely fast and alarmingly thin. Speed tests, camera tests, beautiful...