We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Wireless receiver not working on 2nd keyboard


Jock1e
Resolved

Likes # 0

Logitech K520 Keyboard and M310 both wireless.

I use them on 2 computers using an extra Unifying Receiver that I bought from Logitech.

Never have both computers on at the same time.

1st computer they work ok,The 2nd computer the keyboard will not Pair any more and cannot get it to work but the mouse will work.

I should add that on the 2nd computer I usually have a ps2 mouse connected at all times so that I can pair the keyboard to get it working.

It has worked for 3-4 months without any problems but not any more.

Anyone had the same problem before and knows how to fix it.

Tried everything including removing the drivers ,deleting the Unifyer and reinstalling it

I can only think it is a problem with the reciever that was sent but as it works with the mouse and no longer with the keyboard it has me stumped.

Like this post
Chronos the 2nd

Likes # 0

Batteries all OK, I know it is an obvious question but easy to overlook.

Like this post
woodchip

Likes # 0

Are you pressing the buttons on Keyboard and Mouse in correct Order to link them to the USB Receiver. on mine its button on back of keyboard first followed by the one on bottom of mouse. But I first have to press the button on front of Receiver before the above

Like this post
Jock1e

Likes # 0

Just connected the mouse to it with no problems but the keyboard will not work.

It says batteries are ok on the keyboard but will change them as soon as I can to see if that is the problem.-

Like this post
Jock1e

Likes # 0

Had a pack of Duracell batteries downstairs so tried a couple of the new ones in the keyboard with the same result.No connection.

Just wonder why it will connect to the mouse and not the keyboard.

Like this post
Jock1e

Likes # 0

Ok changed the wireless connector from the computer that the keyboard works and tried it on the second computer and it worked fine on it.

Changed it back to the old connector and the keyboard will not work,Mouse still works but can only assume it is the wireless connector that is at fault.

Had it for just over 4 months it only cost £10 including postage from Logitech is there any warranty on a small item like that.

I have e-mailed them to see but it will take up to 48 hours before they will reply.

Like this post
Chronos the 2nd

Likes # 0

Logitech have one of the best customer service I have come across. I had an intermittent problem of lost USB connection with my G400 mouse. It would have been tricky to RMA it back to Overclockers as the problem was not very obvious.

I got in touch with Logitech and they sent me a prepaid postage label and I returned the mouse, they received it Friday and I have been informed that a new one will be delivered by UPS today.

So it is likely that you will get a new one from them.

Like this post
Jock1e

Likes # 0

Thanks Chronos the 2nd did you phone them or e-mail them.

I e-mailed them so will probably take a bit longer for a reply.

Like this post
Chronos the 2nd

Likes # 0

In the first instance I emailed, then later phoned but that was only because I was a little impatient about the fact that the online webform I had filled in with the tracking details had not been updated when I checked and saw that the mouse had been delivered to Logitech.

Like this post
Jock1e

Likes # 0

Ok will wait and see what they say.

Like this post
Chronos the 2nd

Likes # 0

Just received my G400, brand new and boxed. Might just punt it on as I have just bought a Mionix Saiph 3200. But great service, I had only had the G400 a couple of months or so, so it was the responsibility of the seller to sort it. But with an intermittent problem that was going to be difficult.

If my memory serves it took about 24 hours for the first response after that each email was pretty quick.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Android One vs Android Silver vs Google Nexus: What is the difference?

IDG UK Sites

Apple updates MacBook Pro line-up: Price cuts & spec boosts for 6 MacBook Pro models

IDG UK Sites

Long live the internet fridge: the Internet of Things is coming

IDG UK Sites

How Prometheus' colourist Juan Ignacio Cabrera gave a tense, edgy feel to Chosen