We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Microsoft Office 2010 excel sort problem


Terry Brown

Likes # 0

Updating an Excel database on 2010, I used the custom sort (Sort by field One then Field Two).

The result was a complete mismatch of my data, with the data in the wrong places.

Is this a fault with Excel 2010, as Excel 2003 never had this problem

Terry

Like this post
compumac

Likes # 0

Did you select ALL of the relevant data?

Like this post
Terry Brown

Likes # 0

I have 6 columns of Data (a to f) and about 400 rows, consisting of : Dates (In stock): Descriptors (name):sale Price:Lowest:Highest and expiry dates.

With 2003 , you selected a column (e.g. Number)and it sorted every item across all 6 rows keeping them all perfectly lined up, and this included multiple item sort.

2010 seems to work to a different system and does not do this.

Terry

Like this post
compumac

Likes # 0

But did you select ALL the data - six columns and all rows within your sort -ie ALL of the data required to be sorted? Select ALL data and then sort by by the required column(s)?

Like this post
Terry Brown

Likes # 0

Compumac

Normally you select any one cell, and select the sort you want and this is done for all data -keeping the rows in the correct sequence. If you try to select all the data it does not work, and tells you to select a cell

Like this post
compumac

Likes # 0

Terry I have used Excel 2003 and at this time am using Excel 2007 and the sort function works perfectly by selecting ALL data and then selecting by column and sort on cell values. Have you tried creating another small spreadsheet and try sort on that as it occurs to me that there might be a problem with the spreadsheet that you are working on?

Like this post
HenryF75

Likes # 0

As Terry Brown said In Outlook 2010 only select one cell and click on sort the other columns will follow the selected cell. The sort will be upset if you select a column. Then only the selected column will be sorted.

Like this post
compumac

Likes # 0

HenryF75. You learn something new every day. I was not aware of that as I do not have Excel 2010 only Excel 2003 and 2007. Still does not sort out his problem though.

Like this post
lotvic

Likes # 0

HenryF75 That doesn't sound right, because if you have only selected one column you will not get the options for the other columns/fields in a custom sort. I get a popup telling me there is other data in adjoining cells and warning me they will not be sorted. (but that is in Excel 2003)

Like this post
xania

Likes # 0

I have Office 2010 and have not to date experienced this problem, except where I have accidentally selected one or more columns before using the sort - but as lotvic points out, even then I do get a warning.

To be safe, best select the small box in the top left hand corner of the worksheet (which selects the entire worksheet) or click Ctrl+A )same thing) BEFORE opening the Sort function

Like this post
Woolwell

Likes # 0

Same with Office 2013, unless the columns/rows are not selected correctly then the sort should work.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Nexus 6 vs Sony Xperia Z3 comparison: Lollipop phablet takes on KitKat flagship smartphone

IDG UK Sites

Why people aren't upgrading to iOS 8: new features are for power users, not the average Joe

IDG UK Sites

Free rocket & space sounds: NASA launches archive of interstellar audio on SoundCloud

IDG UK Sites

iPad Air 2 review: Insanely fast and alarmingly thin. Speed tests, camera tests, beautiful...