We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

HDD/BIOS help!


potatological

Likes # 0

My bios isn't listing my hard drive as a bootable device. I have no idea what's wrong! When i start my computer up i get this message:

The current BIOS setting do not fully support the boot device. Click OK to enter the BIOS Setup. then in yellow text: Go to Advanced>Boot>CSM Parameters and adjust the CSM (Compatibility Support Module) settings to enable the boot device.

But not only do i have no idea how the hell to set those parameters, i'm completely unfamiliar with this Asus chipset motherboard and it's drivin me nuts!

Please anyone help me out? Took my computer to geeksquad and they told me i need to order a factory restore disk from Asus and i can't even call till monday to inquire about it! It's been a week of me trying to figure this out and i am literally

Thank you in advance for any help!

My computer model: Asus CM1745

Upgrades i have made: 520 WATT Dynex PSU model: DX-520wps HD Radeon 6870 GPU

Like this post
hssutton

Likes # 0

Oh for an edit button.

the last line should read "Asrock UEFI setup utility is a little different to the Asus.

Like this post
potatological

Likes # 0

Yes. i set it to AHCI and i can confirm that it isn't listed in the boot menu or boot priorities.

Also, yea what you linked isn't my bios. It's the Asus UEFI bios setup, it's weird and seems to me to be really counter productive.

Like this post
Fruit Bat /\0/\

Likes # 0

To get the DVD / HDD drive to show up in the boot menu, you might need to go into the BIOS (actually (U)EFI Settings) and enable Legacy (BIOS) Mode or the UEFI Compatibility Support Module (CSM) or similarly worded option:

Like this post
potatological

Likes # 0

How would i go about doing that?

Like this post
Fruit Bat /\0/\

Likes # 0

Look under Boot

Find Launch CSM - change to Enabled

Then Boot Options #1 or Boot Options #2

You might also have to disable both Boot / Fast Boot and Security / Secure Boot Control.

Like this post
potatological

Likes # 0

The boot options don't show up :L

Like this post
Fruit Bat /\0/\

Likes # 0

The UEFI bios is hybrid it can go either way MSDOS MBR (legacy) - UEFI GPT

See if you can find a setting to put it in MSDOS MBR legacy.

Like this post
Bris

Likes # 0

Boot options are available in the Advanced Mode section of the BIOS.

When you enter the BIOS setup screen, in the top right hand corner you will see EXIT/ADVANCED MODE, click on this and select ADVANCED MODE.

One of the 5 tabs says "BOOT", click on this.

Like this post
potatological

Likes # 0

I know this, i have already done that. I have no lack of familiarity with the typical BIOS procedures, just this UEFI interface and how to access my HDD to boot through it.

Like this post
hssutton

Likes # 0

As I mentioned earlier I had the same problem with the UEFI setup utility on my Asrock P67 Pro board which is a little different from the Asus UEFI setup utility.

Bris stated look in the Advanced mode, I eventually after a lot of head scratching found my problem to be there.

Before discovering the problem lay in the advanced mode I managed to get my computer to boot from my Sata hard drive by disconnecting all other drives, my PC then booted without any problem.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Best Christmas 2014 UK tech deals, Boxing Day 2014 UK tech deals & January sales 2015 UK tech...

IDG UK Sites

LED vs Halogen: Why now could be the right time to invest in LED bulbs

IDG UK Sites

Christmas' best ads: See great festive spots studios have created to promote themselves and clients

IDG UK Sites

Why Apple shouldn't be blamed for exploitation in China and Indonesia