We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Graphics Card Wont Stay in PCI-E Slot unless Pc is laid horizontaly.


LolEmAll

Likes # 0

Hey guys need a hand . pretty sure my card is losing connection when the pc is vertical and even when i screw it ioto the case the card stops running.

The card is a evga nvidia geforce gtx480

It was new about 8 months ago and no problems until this week.

I tried to boot it and it wouldnt do anything, i checked everything was connected and still nothing. so i laid it down to start fiddling and it suddenly booted and worked fine. happy i tip it up to usual position and it hangs and freezes the pc. try and restart.

nothing till i lay it down again. tried my second pci-e slot and still nothing from that standing up. if i screw the card to the case as you should it doesnt run at all as the case never fits perfectly and slightly pulls it away from the mobo.

Anyone have any ideas whats wrong? is it the mobo or card or connectors or am i just an idiot :D

please help

Like this post
wee eddie

Likes # 0

To me, it sounds as if the Slot is damaged in some way.

Are you sure that you are using the correct slot for the Card?

Forget that it is PCI-e, for the moment.

Look carefully at the slot, also any others available, and see if everything lines up correctly.

There are such a multitude of Slot types in use and the main difference seems to be the number of contacts, almost impossible to count, and the position of any cross-slot bars.

Like this post
retep888™

Likes # 0

<<tried my second pci-e slot and still nothing from that standing up>> Theoretically it should work although working in 8x instead of 16x speed yet you seem to have not much luck.

Switching to a new board might be a better idea & save you time, just curious what Gigabyte socket 1366 board are you getting? Can you still get a new board or used?

My socket 1366 Asus Rampage II Extreme bought in 2008 back still works but now resides in a drawer, am using an IvyBridge Asus Maximus V Extreme, great board.

Like this post
bumpkin

Likes # 0

Sounds like a dry joint on the card, try standing the machine up and pushing and wiggling the card about and see what happens if anything.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Microsoft Band UK release date and price rumours, features and specs: Microsoft smartwatch unveiled

IDG UK Sites

Why Sony's PS4 2.0 update is every gamer's dream (well, mine at least)

IDG UK Sites

This Grolsch ad combines stop-motion & CG for majestic results

IDG UK Sites

Apple rumours and predictions for 2015: What to expect from Apple in 2015