We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
 
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Laptop Power On - Screen Stays Black - Fan Goes Off 5 Seconds


andantesash

Likes # 0

Im having some problem with my Packard Bell EasyNote TJ61 - I powered it on and the fans whirred like normal and the lights on the keyboard came on like normal - the button lit up. But the screen stayed black. Then the fans went silent after 5 seconds and it sounded like it was switched off but all the lights were still on - the power, hard drive and keyboard ones. I noticed if I run my finger over the touch pad buttons for volume etc they light up so im not sure whats wrong.

I replaced the screen on the laptop the other day and it was working fine until last night and this has happened. Any suggestions?

I've tried replacing ram / replacing hard drive / pulling the cmos for 30mins / unplugging and trying the 30 seconds power button trick but nothing.

Any suggestions?

Like this post
Jock1e

Likes # 0

Plug it into another monitor or TV and see if it works on that.Could be the back light I suppose.

Try the old way and remove the battery and power cord.

Then hold the start button for about 50 seconds.Battery and power cord back on and see if it will start.

I suppose you could try starting it in safe mode to see if it makes any difference.

Like this post
andantesash

Likes # 0

I've tried the external monitor - nothing happens

I done the battery and power cord remove and pressing power on - doesnt make any different

I can't get it into safe mode because nothing comes on the screen the minute I turn it on

Like this post
rdave13

Likes # 0

It sounds like a bad connection since you changed the screen. Possibly it was fine until you closed and opened the lid.

Like this post
Jock1e

Likes # 0

I have to think your back light may be needing replaced is there any way you could have moved it when installing the new screen.

I don't suppose it Will go into the Bios either then.

I don't suppose the new screen could be faulty or not connected properly.

Like this post
Fruit Bat /\0/\

Likes # 0

I would forget the screen problems if its not working on an external monitor

(you did remember to press the appropriate button to get it switched to external?

mains only no battery attached - no hdd or DVD will it boot to BIOS or error message?

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Netflix to introduce price increase: New subcribers to start with

IDG UK Sites

How to join Apple's new OS X Beta Seed Program: Run pre-release versions of OS X on your Mac

IDG UK Sites

Why our gadgets will kill us all: bleating notifications, too many chargers and the proliferation...

IDG UK Sites

See Moo Studios' new animated advert for Blue Moon beer