We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Monitor not picking up signal


CPUNerd

Likes # 0

Friend has recently been building a new pc from scratch. He's bought a new case, mobo, GPU, PSU and some ram, I put the pc together.

Mobo - gigabyte 970a-ds3 Card - MSI had 7850 GPU - ambiance 80+ 700w

I turned the pc on and everything is spinning, even the GPU fans but there is no signal being picked up, help? There is no on board graphics for the motherboard so I'm guessing that I shouldn't have to enable the pci-e slot? Any help please? The had was from his existing PC.

Sorry about any dodgy writing, on an iPad 2 at the moment haha...

Like this post
Fruit Bat /\0/\

Likes # 0

Power to the card fan running?

recheck video cable to monitor

Like this post
Secret-Squirrel

Likes # 0

"...........MSI had 7850 GPU.."

If you mean the graphics card is an "MSI HD 7850" then that particular model has an onboard six-pin PCI-E power connector that needs to be connected to the PSU. Have you done this? If you haven't then that would account for your symptoms.

Like this post
CPUNerd

Likes # 0

Yeah, all the fans are spinning and everything is running but the monitor is detecting that a VGA or HDMI cable is being plugged in but not outputting any image.

Thankyou for correcting me on the HD part, that was the iPad's fault, I was round my friends house trying to work out why it wasn't working but now i'm home I can write a better reason.

He is upgrading his computer from a stock Vi Box that he bought on eBay numerous years ago and he was sick of being unable to play high end games so I told him what he needed and to go any buy it, so he did and over the next couple of weeks the parts started to arrive. Once everything had arrived I built the computer for him as I have computer building knowledge after building my fair share of them, but this is the first time I have encountered a problem such as this. All the fans in the case are spinning, the board is receiving power from the 4Pin ATX because the Heat Sink fan is spinning, So I know its not a board issue also it was brand new, even the fans on the GPU are spinning because yes, the 6pin cable is plugged in but it's not giving an output off, is this a compatablitiy issue? SPECS: | MOBO = Gigabyte 970A-SD3 | GPU - MSI HD 7850 | GPU - PSU | Ambiance 80+ 700w | I usually work with Intel but I don't think that with it being AMD it would make a difference?

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Android One vs Android Silver vs Google Nexus: What is the difference?

IDG UK Sites

Apple updates MacBook Pro line-up: Price cuts & spec boosts for 6 MacBook Pro models

IDG UK Sites

Long live the internet fridge: the Internet of Things is coming

IDG UK Sites

How Prometheus' colourist Juan Ignacio Cabrera gave a tense, edgy feel to Chosen