We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Internet Explorer 9 recent problems with loading webpages and slow responses


Jimbo4

Likes # 0

I am running windows 7 with Internet Explorer 9 update version 9.0.12(KB2761465) all was working O.K. until about 6 weeks ago when some pages do not load correctly and the response from some sites is very slow. I have downloaded and installed Google Chrome to compare and all works O.K. using Chrome. Have I got a corrupted update ? in explorer 9 and if so how do I check and sort it out?

Like this post
Jock1e

Likes # 0

maybe download I/E10.

Or go to tools Internet Options.Advanced and press reset.That resets I/E to its original state.

Have you downloaded the most recent Windows Updates as there were a few for I/E.

Like this post
Jimbo4

Likes # 0

Jockie

Thanks . I thought IE 10 was not fully compatible with windows 7. IE 9 is fully updated from automatic windows updates. No outstanding updates are listed. Worked fine until around 6 weeks ago

Like this post
Jock1e

Likes # 0

Go back into advanced settings and this time press restore advanced setting and see if that helps.

I take it you did not try the reset button.

If it is the 64 bit version you have, make sure you use the 32bit version of I/E.

And tick or untick compatibility

Like this post
Woolwell

Likes # 0

IE10 is only at Release Preview stage for W7. Doubt that it will solve the problems. Try reset as Jock1e has suggested. Try running with out add-ons (accessed through all programs, accessories, system tools) and see if it is ok then. Try the problem sites in compatibility mode. Lastly stick with Chrome which IMO tends to to be better.

Like this post
Jimbo4

Likes # 0

Jockie

Many thanks have now tried the "reset" option and it seems to have cured the problem

jimbo4

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Acer Aspire R11 review: Hands-on with the 360 laptop and tablet convertible

IDG UK Sites

Apple Watch release day: Twitter reacts

IDG UK Sites

See how Framestore created a shape-shifting, oil and metal based creature for Shell

IDG UK Sites

Apple Watch buying guide, price list & where to buy today: Which Apple Watch model, size, material,?......