We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

PC Not Starting, No POST Screen


Rob Gibson
Resolved

Likes # 0

Hi All,

On pressing the power button the fans start and the red activity LED on the case flashes for a few seconds, but after that nothing else happens and the monitor remains blank except for a "No Signal" message (monitor generated).

On a normal start up the monitor shows the "Chilllblast" logo momentarily, before going on to the POST screen, etc.

Seems to me that the machine isn't even getting as far as the BIOS.

It is nearly five years old and I was thinking of changing it later this year, so won't want to spend too much on it!

Any suggestions appreciated.

Rob.

Like this post
Diemmess

Likes # 0

Thanks for your follow-up, it seems obvious now we know!

Yonks ago a friend had just received a brand new PC. Same symptoms.

He phoned the suppliers who said make sure the graphics card was properly seated. He did that and they lived happily ever after!

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Amazon Kindle Voyage release date, price and specs UK: a high-end eReader with Amazon’s best-ever...

IDG UK Sites

Why local multiplayer gaming is rapidly vanishing: we look at the demise of split-screen and LAN...

IDG UK Sites

How to successfully bridge the gap between clients and creatives

IDG UK Sites

How to update your iPhone or iPad to iOS 8: including how to install iOS 8 if you don't have room