We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

PC Wont Start


Legslip

Likes # 0

I press the power on button and the lamp behind glows for about three seconds, I can hear the Power Supply fan start and then it switches off. Nothing on screen at all, no boot sequence. Any thoughts?

Like this post
rdave13

Likes # 0

First thing that came to mind is have you moved the PC lately? It could be a loose sata connection, or other, inside.

Like this post
compumac

Likes # 0

A Medion PC?

Like this post
Taff™

Likes # 0

rdave13 - he would still get the POST screens though. This sounds like the Power Supply Unit has a problem. Remove the kettle lead and hold down the power on button for 45-60 seconds then try again. Any difference?

Like this post
Legslip

Likes # 0

Cheers chaps gonna try swoppin the PSU. Will advise.

Like this post
Legslip

Likes # 0

Cheers chaps gonna try swoppin the PSU. Will advise.

Like this post
woodchip

Likes # 0

PSU should do it unless it as taken out other hardware with it

Like this post
Legslip

Likes # 0

Thanks all. PSU was the problem.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

45 Best Android games: top Android games for your smartphone or tablet in 2014 (24 are free!)

IDG UK Sites

How Apple, Adobe, Microsoft and others have let us down over UltraHD and hiDPI screens

IDG UK Sites

Do you have the X-Factor too? Mix Off app puts fans in the frame

IDG UK Sites

iPad Pro release date, rumours and leaked images - 12.9 screen 'coming in 2015'