We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

HELP!!! LAPTOP WONT FIRE UP AT ALL!!!


laptopdunce

Likes # 0

I logged off my Acer 5535 laptop lat night and now it wont fire up at all, the power adaptor is fine, its charging the battery and its nothing to do with my router as I am runing a little netbook in its place, the screen is totally blank and it wont open up the windows XP homepage at all, its totally dead, there is no wifi lamp lighting up, I cant imagine what can be wrong here, these things ALWAYS happen when I am travelling!!! I cant even get any keys to work, its lighting up the battery charging light only! I can feel it getting warm underneath and the fan is working in the HD area,will I be able to retrieve any of the date on the HD and will I need to buy a complete new laptop?? SH*T SH&T SH8T!!! thanks LAPTOPDUNCE

Like this post
Secret-Squirrel

Likes # 0

This simple tip can frequently work wonders with laptops where the lights come on but there's nothing on the screen:

Disconnect the power-supply plug from the laptop then remove its battery. Finally, hold down the power button on the laptop for ten seconds. Reconnect everything and turn it on.

Like this post
Secret-Squirrel

Likes # 0

"I take it you tried it in safe mode....."

That might be a bit tricky because the OP said "the screen is totally blank", "its totally dead" and " I cant even get any keys to work" ;)

Like this post
lotvic

Likes # 0

Secret-Squirrel's "hold down the power button on the laptop for ten seconds" that sorts it most times but I always suggest at least 30 seconds to make sure the all the volatile memory and static has been discharged. (same trick works on tv PVR's equipment)

Like this post
rdave13

Likes # 0

Similar to Secret-Squirrel's post, link, not sure about connecting the battery back again with the power cord still connected.

Like this post
laptopdunce

Likes # 0

I have taken the battery out (the housing is a bit loose and battery has to be taped in most times but it charges OK) disconnected the power adaptor and removed battery and held down the power on button for more than 30 seconds, then reconnected power adaptor cord ONLY and then pressed power button on and then quickly off, then put the battery back in and turned it on again, and it is showing the power on light and battery charing light but nothing else, blank screen, no keys working, but HD fan working and gets warm, OOOhhhhheerrr!!! I just dont understand how this can have happened overnight, after it logged off OK and I disconnected power at plug last night. Its an ACER 5535 aspire laptop thanks, LAPTOPDUNCE

Like this post
lotvic

Likes # 0

If it was me, I would take out the harddrive (to keep it and data safe) then concentrate on getting the laptop to boot up into bios screen. Only when I'd 'mended' it to the stage where it says it can't find an operating system would I consider putting the harddrive back in.

First things to check are connections, have you tried wriggling the lid it might be the hinge cables are loose (it sounds as if the laptop is a bit battered ;0)

Like this post
lotvic

Likes # 0

Not got experience with laptop screens, but isn't there a backlight and if it goes then you get a black screen?

Like this post
difarn

Likes # 0

Just an observation - can you check the lid closed switch hasn't become jammed - it is usually located near the hinges. Try pressing it in a few times.

Do you have another power adapter? It is possible that a faulty adapter can supply just enough power to light up the power light and a fan but not much more.

Like this post
Fruit Bat /\0/\

Likes # 0

Need to determine if its not booting or just screen / graphics

HD fan working and gets warm and sound from hard drive?

tried connecting to an external monitor or TV?

tried removing HDD and see if it boots to error message?

Like this post
rdave13

Likes # 0

Hope it's not this problem, link

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Best camera phone of 2015: iPhone 6 Plus vs LG G4 vs Galaxy S6 vs One M9 vs Nexus 6

IDG UK Sites

In defence of BlackBerrys

IDG UK Sites

Why we should reserve judgement on Apple ditching Helvetica in OS X/iOS for the Apple Watch's San...

IDG UK Sites

Retina 3.3GHz iMac 27in preview: Apple cuts £400 of price of Retina iMac with new model