We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:

PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom

It's free to register, to post a question or to start / join a discussion


Canon Pixma MG5450 - NT 4.0 Policy: Driver Issue Read more: http://www.pcadvisor.co.uk/forums/28/wi


Likes # 0

EDIT: Moving this from the Windows 7 Forum as it doesn't seem to fit purpose there :Old Forum Here

Here's my issue I'm having:

I bought a MG5450 2 days ago and began setting it up yesterday however stumbled across an issue where the printer driver would not install regardless of the compatibility setting. Being as it's a newly released printer I thought the drivers would be up to date and new, however I think there may be a issue with NT 4.0 driver policy as when I try to install the drivers through the device manager, it gives me that message that there's a policy in place stopping me.

Windows update always fails when trying to install the printer, however the scanner, and software included all work fine. I can scan images on wirelessly and have them saved on my computer without an issue, however there is no way to print.

I have tried disabling the policing through the 'MSC' and adding a local group policy or something along those lines. However none of this has worked. How can I get the driver to install or disable the policy to allow the printer to be installed.

Running Windows 7 Ultimate 64x

Tried installation of the drivers both through wireless and wired, both come to the same outcome.

Any other information needed, then please ask.


I have tried the following:

No.1 - Tried compatability settings to which they failed and said was no compatible with my operating system

No.2 - Disabled the option 'Disallow for kernel drivers to be installed' I have disabled this in the Registry and another method (Something.msc)

No.3 - I have downloaded Canon's up to date Windows 7 64x drivers from their website, and the drivers still fail

No.4 - Windows update finds the driver find, installs and then fails

No.5 - Tried the 'Add Printer' function and that's where the NT 4.0 message appears.

I am complete stuck and baffled by this issue!

Like this post

Reply to this topic

This thread has been locked.

IDG UK Sites

Best camera phone of 2015: iPhone 6 Plus vs LG G4 vs Galaxy S6 vs One M9 vs Nexus 6

IDG UK Sites

In defence of BlackBerrys

IDG UK Sites

Why we should reserve judgement on Apple ditching Helvetica in OS X/iOS for the Apple Watch's San...

IDG UK Sites

Retina 3.3GHz iMac 27in preview: Apple cuts £400 of price of Retina iMac with new model