We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Mouse buttons no longer responding


Podracer

Likes # 0

A problem I have never come across before; Windows Vista on a quad core Hewlett Packard with plenty of RAM and HDD space.

Without warning the mouse buttons have ceased to have any effect. The pointer moves fine, but trying to click on the start menu, on any icon, or anything at all (eg, if using menus in MS Word) produces no effect.

We have changed the mouse, but to to avail (the original mouse works fine on another computer) - so it is not the mouse. Interestingly, trying to use the Windows key also has no effect, so the only way of shutting down is to hold down the computer switch. When we re-boot it, the mouse may OK for a few minutes, then the buttons (both left and right) cease to (but the pointer still moves).

We have installed no new software, and all anti-virus and malware scans are up to date and show no problems. Googling the problem does not come up with anything meaningful. Any useful suggestions would be very much appreciated.

Like this post
Jock1e

Likes # 0

See if it works ok in safe mode and maybe do a last good configuration on it while you are in there.

You don't use Tune up utilities do you as I had the same sort of problem while using it.

Basically it is your screen that is freezing so probably nothing to do with the mouse.

Try device manager to see if any problems.

If it works ok in safe mode it is probably a driver problem.have you tried updating the driver.

Like this post
Podracer

Likes # 0

Jock1e - Thanks for the suggestions and the fact it may be the screen, not the mouse. We will try your suggestions and see how it goes. Incidentally, I use CCleaner (and do so on three other computers for several years) (never used Tune Up Utilities) and have never had any problems with this computer or any of the others.

Update the driver - for the screen (PC has a separate graphics card, so presumably update the graphics card driver??). Or try to update the mouse driver??

Like this post
Jock1e

Likes # 0

I would try and update the mouse driver just in case it is that.

While in Device manager see if there are any yellow exclamation marks beside any of the programs.

Also try View and tick show hidden devices then go back and check in plug and play to see if any problems in there.

Most folk use C Cleaner without any problems.

I take it pressing Ctrl Alt and del at the same time does not take you into Taskmanager either.

Has this just recently happened I don't suppose it could have been anything to do with the windows updates last week.Or have you changed any of your security programs recently.

Like this post
woodchip

Likes # 0

Right Click on Desktop/properties/Settings/advanced troubleshooting look for the Slider that is for troubleshooting and drop it down a notch at a time.

You could also try updating Graphics Driver

Like this post
Nontek

Likes # 0

I recently had a similar problem with a wireless mouse - changing the battery fixed it!

Like this post
bumpkin

Likes # 0

Try the easiest things first, battery would be my first option, may not be but saves you going off on a tangent and wasting a lot of time if it is.

Like this post
lotvic

Likes # 0

Try using keyboard instead of mouse clicks:

you can open the Microsoft Windows Start button by pressing the CTRL and ESC keys at the same time.

Once in the Start menu you can use the arrow keys on the keyboard to move up, down, left, or right in the start menu. Once you've located the program you wish to run, press the Enter key.

http://www.computerhope.com/issues/ch000791.htm

http://www.computerhope.com/issues/ch000542.htm

Like this post
Jock1e

Likes # 0

lotvic

Don't think the keyboard works either.He has tried pressing the Windows key with no response.I presume it is a screen freeze where nothing works.I think we have all been through that at one time or another.

No comments from them yet to see if it works in safe mode or not.

Like this post
Podracer

Likes # 0

Everyone - thanks for your attempted help, but no joy so far. First thing is that this is an intermittent problem, and the mouse may be fine for a day - or for half an hour - and then cease it's ability to click. It is not an individual mouse problem; we have tried another mouse and the result is the same (and the mouse works fine on another computer).

I have checked the mouse drivers (all up to date), but have updated the graphics card driver. in the Device Manger, everything is working fine (or so it claims). I have also gone back to a previous restore point (several weeks ago before this happened, and still the same result - intermittent mouse misbehaving.

When the mouse buttons freeze, the keyboard short-cuts (eg, Cntrl/esc) do not work.

It seems to work fine all the time in safe mode.

As you can imagine, as this is an intermittent fault, it takes time to see if anything I do has any effect.

Next step (for which the computer is overdue for anyway), is a re-installation of Vista - which is helped by the fact that the PC has two completely separate hard discs so back ups are easier. However, considering waiting for another week or so, and I might put 8 on it instead.

In the meantime, thanks for your suggestions.

Like this post
Jock1e

Likes # 0

Maybe run chkdsk just to be in the safe side.Tick both boxes and it should repair any faults it finds.

If it was a bad hard drive maybe you would have the same problem with W/8.

W/8 like you say will be out in 8 days only £25 if you upgrade from the internet so we hear.

If it runs normally and not slow in safe mode there would be no need to do chkdsk.

Have you tried sfc /scannow in command prompt to see if it found any problems.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Android One vs Android Silver vs Google Nexus: What is the difference?

IDG UK Sites

2014 Mac mini release date, specs, rumours: When's the new Mac mini coming out?

IDG UK Sites

Long live the internet fridge: the Internet of Things is coming

IDG UK Sites

How Prometheus' colourist Juan Ignacio Cabrera gave a tense, edgy feel to Chosen