We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

How to increase wireless signal strength?


Border View

Likes # 0

My OS is Windows 7 Home Premium (64 bit) On a desktop computer with a wireless card inbuilt. My ISP is o2. I have o2's wireless router called Technicolour. My router is situated about 10 feet away from the desktop, yet my signal strength is only fair. Two bars, sometimes three, out of a possible five.

How do I increase the signal strength? My router syncs at about 2.9 Mbps and my download speed shows 2.4 Mbps. It has been known to drop to 0.3 Mbps and 1.5 Mbps.

Your help would be appreciated.

Like this post
Zak

Likes # 0

Moving the position of the router may help. Otherwise I would connect using the ethernet cable. Normally some loss of signal strength using a wireless connection.

Like this post
Zak

Likes # 0

Add

What speed can you get using the ethernet cable; perhaps the drop in speed is due to congestion or some other factor, such as electrical devices being switched on.

Like this post
Woolwell

Likes # 0

Try changing the wireless channel and see if that makes a difference.

Like this post
Border View

Likes # 0

I've turned the tower around so that the aerial is pointing towards the router. Moved various wires to they are not blocking any signal and now have four bars. Connection via ethernet not really an option.

Are there drivers for a wireless card?

Like this post
Woolwell

Likes # 0

If it is working then you do not need to change the drivers. Your problem is a frequent one with towers as the tower itself can block the signal. Have you tried changing channels?

Like this post
woodchip

Likes # 0

It may just be the Wireless card is a poor one, Try using a Wireless USB dongle after turning off the Wireless in your Laptop

Like this post
Woolwell

Likes # 0

woodchip - it's a desktop.

Like this post
Border View

Likes # 0

Thank you all for responding. How do I change channels please.

Like this post
Woolwell

Likes # 0

Like this post
woodchip

Likes # 0

it still applies, laptop or desktop. try a USB wireless dongle

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

The 30 best TV shows on Netflix UK: Our pick of the best programmes you can watch right now

IDG UK Sites

Nostalgia time: Top 10 best selling mobile phones in history

IDG UK Sites

VFX Emmy: Game of Thrones work garners gong for Rodeo FX

IDG UK Sites

Apple 13-inch MacBook Pro with Retina review (2.6GHz, 128GB, mid-2014)