We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

New PSU not powering up


alsattic

Likes # 0

Hi, I bought a new PC and after 1 week it would not switch on. Thinking PSU, replaced with old unit from old PC. All started to work OK. Ordered new unit with greater power, but on installing would not power up. Checked unit by shorting green wire to earth and powered up ok. Checked original unit and this did the same. So now I have 2 working PSU's which do not work in my PC. The old PSU is still working OK. Checked new PSU's in old PC and they both work OK. Is this a BIOS problem? MoBo is ASUS M5A 78l-M LX Bios ver 0801 dated 30/11/2011 It has been making me go round in circles. Any body any ideas? Thanks

Like this post
rdave13

Likes # 0

Front switch possibly? If it's new it should be under warranty.

Like this post
alsattic

Likes # 0

Front switch is fine, did a continuity check on it, also it works OK with the old PSU unit

Like this post
KRONOS the First

Likes # 0

Motherboard fault perhaps?

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Acer Aspire R11 review: Hands-on with the 360 laptop and tablet convertible

IDG UK Sites

Apple Watch release day: Twitter reacts

IDG UK Sites

See how Framestore created a shape-shifting, oil and metal based creature for Shell

IDG UK Sites

Apple Watch buying guide, price list & where to buy today: Which Apple Watch model, size, material,?......