We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:

PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom

It's free to register, to post a question or to start / join a discussion


canon scanner suddenly stopped working


Likes # 0

I have a Canon canoscan Lide 100 - had it since 20O9 & used regularly and frequently since then. Afew days ago I suddenly I got error message that it was "not installed properly". As far as I know I had not changed anything, nor installed or uninstalled anything that would affect it. Same OS throughout (Vista) & same Pc throughout. I've now re-installed it using the original disk, and tho on completion the message says " ready for use" or words to that effect, when I try to use it I get the same error message as before about "not installed properly".

Any suggestions , please. One day all was Ok, the next it doesn't work at all.

Like this post
Terry Brown

Likes # 0

In case Microsoft Updates have caused a problem, try uninstalling it. Shut down completely and restart computer.Reload the software but this time use the Compatible mode for either Vista or XP, to see if it makes a difference.

I don't know if this will help, but I have an HP PSC750 which is basically a workhorse (Prints out from 30 to 100 sheets daily), which stopped working.

Done the same as you uninstalled -reinstalled- unplugged power and USB- no difference, then I was told by an ex-computer engineer about a reset.

On mine -Unplug the USB and start printer, while it is booting up I had to Press the cancel key and the Enter key together and wait for a beep, then press the left Menu button.

This performed a Factory reset- Cleared the paper count, language bar everything and I had to reset them all up as a new printer. Worked fine ever since.

The paper count before I reset it was (about) 18500, and it returned to Zero

Like this post

Reply to this topic

This thread has been locked.

IDG UK Sites

Acer Aspire R11 review: Hands-on with the 360 laptop and tablet convertible

IDG UK Sites

Apple Watch release day: Twitter reacts

IDG UK Sites

See how Framestore created a shape-shifting, oil and metal based creature for Shell

IDG UK Sites

Apple Watch buying guide, price list & where to buy today: Which Apple Watch model, size, material,?......